Itoo Software Forum

Author Topic: Issue with Forest Pack Lite 3ds Max Arnold Rendering On Max 2021  (Read 3799 times)

Jack

  • Newbie
  • *
  • Posts: 1
Des anyone have any suggestions.

I've upgraded from 3ds max 2019 which I used ForestPack v 6.3.1 to
3DS Max 2021, for which, i've installed ForestPack lite 7.1.2  to test it out before I repurchase

ForestPack renders with scanline fine...when I render with Arnold it crashes Max with the following applicaiton error prompt: "application error
An error has occured and applicaiton will now closed"   

Here is the final entry from the 3DS Max log file: "
2021/10/29 18:50:47 DBG: [23272] [23140] FOREST 7.1.2 'Forest001'(R): Starting BuildMesh(0)
2021/10/29 18:50:48 DBG: [23272] [23140] FOREST 7.1.2 'Forest001'(R): Exiting BuildMesh (78511 items, code 0)
2021/10/29 18:51:17 DBG: [23272] [23140] FOREST 7.1.2 'Forest003'(R): Starting BuildMesh(0)
2021/10/29 18:51:17 DBG: [23272] [23140] FOREST 7.1.2 'Forest003'(R): Exiting BuildMesh (1925 items, code 0)
2021/10/29 18:51:17 ERR: [23272] [23140] An exception occurred while rendering with 3ds Max."

I can get it to Render if i set the render mode to "Meshes" instead of Automatic but then i run into various memory render issues and no render outputs.  Especially if i render with GPU.

I didn't have issus with 2019 Max GPU  Arnold Render.   



Max to A Version 5.0.1.4
Arnold: 7.0.0.0 [47ab20b9]

Nividia drivers up to date and Max is the newest version.
« Last Edit: October 30, 2021, 02:33:02 AM by Jack »

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 4384
    • iToo Software
Re: Issue with Forest Pack Lite 3ds Max Arnold Rendering On Max 2021
« Reply #1 on: October 31, 2021, 08:44:28 AM »
Arnold 7 is not compatible with Forest 7.1.2. We must recompile our plugins to support it.
A beta of Forest Pack Pro will be available in the next days (Forest Lite will take more time).

Please, downgrade MaxToA to 4.3.4. That should fix the problems:
https://www.arnoldrenderer.com/download/archive/arnold-for-3dsmax/4.3.4.12/

Carlos Quintero
iToo Software

Dustin

  • Newbie
  • *
  • Posts: 36
Re: Issue with Forest Pack Lite 3ds Max Arnold Rendering On Max 2021
« Reply #2 on: July 12, 2022, 06:21:49 AM »
This didnt fix my issue with 7.1.2. What would be my next step? Is there a new version of Arnold that works with this version of FP? I also have FP 7.30 available and Max to A 5.0. Its frustrating keeping all of these versions correct. Max 2020.
« Last Edit: July 12, 2022, 06:23:40 AM by Dustin »

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 4384
    • iToo Software
Re: Issue with Forest Pack Lite 3ds Max Arnold Rendering On Max 2021
« Reply #3 on: July 12, 2022, 09:24:32 AM »
I understand your frustration, but unfortunately we only can make each Forest update compatible with one Arnold version.
When we compile a new version of the plugin, we use the latest Arnold SDK available, so the plugin is compatible with it.

To make things worse, there are different numerations between the Arnold version (currently 7.1), which the MaxToA package which includes it (currently 5.3.2.6).

As general rule, we suggest to use the latest Forest update from our website, and the latest MaxToA package available for your 3DS Max version, which are available here.
Futhermore, Autodesk doesn't provide MaxToA updates to all Max versions (for example Max 2020 is not included in latest udpates). In this case, you can search the latest MaxToA for your Max version in the archive

I can confirm the latest MaxToA available for Max 2020 (MaxToA 5.2.0.46) works fine with our latest Forest version (7.4.3).

If you have not access to the latest Forest update, you should try with an older MaxToA package.
Carlos Quintero
iToo Software

Dustin

  • Newbie
  • *
  • Posts: 36
Re: Issue with Forest Pack Lite 3ds Max Arnold Rendering On Max 2021
« Reply #4 on: July 13, 2022, 03:54:40 AM »
Thank you, I now believe when I installed the older version of Arnold, it never overwrote the newer version, so I just had the same version crashing. I'm going to try again by un-installing the newer version first.

UPDATE: This fixed it.
« Last Edit: July 13, 2022, 04:07:05 AM by Dustin »