Itoo Software Forum

Author Topic: I can't get shadows with my trees -  (Read 3043 times)

ron_ADST

  • Newbie
  • *
  • Posts: 4
I can't get shadows with my trees -
« on: September 26, 2010, 12:03:14 PM »
When i try to get shadows to my trees nothing happens.

I put the shadowmaps in the forestmaterials. Now I should link the material to the shadowmaps in my light but in a daylight system there is no shadowsrollout. Do I have to use a different light or is there a different option?

kind regards Ron

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3076
    • iToo Software
Re: I can't get shadows with my trees -
« Reply #1 on: September 26, 2010, 12:27:05 PM »

Are you using Mental Ray ?

If so, it's not needed to use XShadow (or other shadow maps), it's only applicable to the Scanline renderer. Please, try this:

1. Use Forest Material for your materials
2. Assign the light in Forest->Shadows->Raytrace->Light

That's all. You can see a guide to use billboards with different renderers here:

http://www.itoosoft.com/forum/index.php?topic=448.0

If you are rendering 3D trees,  there is not any special requirement. The shadows must work with Forest as any other object in the scene.

Carlos Quintero
iToo Software

ron_ADST

  • Newbie
  • *
  • Posts: 4
Re: I can't get shadows with my trees -
« Reply #2 on: September 26, 2010, 12:45:28 PM »
I'm using Lite on the moment

A daylight system - (MR)

in Forest - Shadows - I checked default

I put the shadow maps to the material

..... use fake shadows has to be uncheked? ....

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3076
    • iToo Software
Re: I can't get shadows with my trees -
« Reply #3 on: September 26, 2010, 01:16:36 PM »

You need to set these options in Forest->Shadows:

- Use Fake Shadows - Enabled
- Vertical - Enabled
- Horizontal - Optional, only if you assign a horizontal shadow map in the material
- Raytrace->Light - Pick the daylight sun light

If you are using Forest Material with a Standard material (the recommended combination for MR), it's not necessary to assign a shadow map in the material, Forest uses the opacity map for the shadow.

If you like, post here the scene for checking.

Carlos Quintero
iToo Software

ron_ADST

  • Newbie
  • *
  • Posts: 4
Re: I can't get shadows with my trees -
« Reply #4 on: September 27, 2010, 09:30:04 AM »
....

for stupid people like me (!) - maybe it is better to change the name of the button from none to pick light?

Finaly I understand. Thanks

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3076
    • iToo Software
Re: I can't get shadows with my trees -
« Reply #5 on: September 27, 2010, 11:34:05 AM »

The 'none' label is set by default in the pick buttons by Max, but i think it could be changed. We'll take a look to it.

Thanks for the suggestion !

Carlos Quintero
iToo Software