Itoo Software Forum

Author Topic: [SOLVED] Bug | Forest Pro 4.2.2 VrayDR  (Read 1929 times)

IT1371

  • Full Member
  • ***
  • Posts: 131
[SOLVED] Bug | Forest Pro 4.2.2 VrayDR
« on: April 23, 2014, 09:05:03 PM »
This issue never happend in v4.1.6.
Unfortunatly I cannot send a test scene because I was unable to replicate the problem, but it happend in 3 different projects.
In all projects the issue is EXACTLY like described below.

I use 3ds max built in batch render dialoge to setup my renders.
Cameras 1 and 2 render excellent, but in all projects always camera 3 doesn't render the Forest object properly.
All pojects started in 4.2.2 so it is not a migration issue.
Also, this forest object is visible in cameras 1 and 2 and also, in camera 3 the same object which is a little far away from the camera renders without issues.



This is a crop image of Camera 3:
Blue mark is rendered OK.
Red mark is the ISSUE.

NOTE: both are the same Forest object!!
All paths are networks paths and visible to all nodes.
If I render the same camera 3 without batch render, everything renders fine.

All nodes including WS are:
Windows 8.1 Pro Update 1 64bit
3Ds Max Design 2014 SP5
Vray 2.40.04
« Last Edit: April 25, 2014, 07:32:30 AM by 3dcrgr »

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Bug | Forest Pro 4.2.2 VrayDR
« Reply #1 on: April 24, 2014, 09:06:24 AM »
This is a known issue: V-Ray DR + Batch Render + Camera Clipping with "Auto assign to active view" produces erratic results. This is not a problem of 4.2.2, it was present in older releases too. It's strange it didn't fail before to you...

Unfortunately there is not a workaround for that. Because the way that DR handles the scene, it doesn't receive correctly the view change notification when using  batch render. Other rendering modes, as Backburner, should work fine.
Carlos Quintero
iToo Software

IT1371

  • Full Member
  • ***
  • Posts: 131
Re: Bug | Forest Pro 4.2.2 VrayDR
« Reply #2 on: April 24, 2014, 09:47:46 AM »
This is a known issue: V-Ray DR + Batch Render + Camera Clipping with "Auto assign to active view" produces erratic results. This is not a problem of 4.2.2, it was present in older releases too. It's strange it didn't fail before to you...

Unfortunately there is not a workaround for that. Because the way that DR handles the scene, it doesn't receive correctly the view change notification when using  batch render. Other rendering modes, as Backburner, should work fine.

So disabling one of the above should solve the issue?
If I drop  Camera Clipping with "Auto assign to active view" or will find an alternative to Max Batch Render it should work properly?

I cannot drop VrayDR because Backburner assigns render per frame and doesn't use all nodes for same frame. I have more nodes then frames most of the times.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Bug | Forest Pro 4.2.2 VrayDR
« Reply #3 on: April 24, 2014, 10:27:44 AM »
That's it. You would disable "Auto assign to active view", but in this case it's necessary to assign the camera manually before each render. So, if it's not essential, i suggest to disable camera clipping completely. That should solve the problem.
Carlos Quintero
iToo Software

IT1371

  • Full Member
  • ***
  • Posts: 131
Re: Bug | Forest Pro 4.2.2 VrayDR
« Reply #4 on: April 25, 2014, 07:27:35 AM »
That's it. You would disable "Auto assign to active view", but in this case it's necessary to assign the camera manually before each render. So, if it's not essential, i suggest to disable camera clipping completely. That should solve the problem.

Thank you, worked great.
If there some alternative batch render that does work properly with camera clipping?

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Bug | Forest Pro 4.2.2 VrayDR
« Reply #5 on: April 25, 2014, 09:56:26 AM »
Quote
If there some alternative batch render that does work properly with camera clipping?

As far as i remember, only Backburner. DR also works, but it's necessary to launch each render from the Max session (if not, activew view is not updated).
Anyway, i will look again if there is some possibility to fix this limitation with batch render.
Carlos Quintero
iToo Software