Itoo Software Forum

Author Topic: Animation and Rotate  (Read 2235 times)

thearkitec

  • Newbie
  • *
  • Posts: 5
Animation and Rotate
« on: September 03, 2010, 04:22:06 PM »
I have a question and a problem hopefully I can get resolved...

We are creating a fly through animation around a building. I have used closed splines to create vegetation beds. I have set each forest "area" to be assigned to the camera. One of the biggest problems I have is how the billboards rotate as they follow the camera. They do not rotate per billboard but some random center point.. So, from one angle it looks great but when I get to the other side and view the same plants.. they are in the middle of the street.

Is there a way for each billboard to rotate around itself...  This is happening at parking islands, virtually every!!!!

Thank you,

Arkitec

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3320
    • iToo Software
Re: Animation and Rotate
« Reply #1 on: September 03, 2010, 05:42:35 PM »
Have you copied the Forest objects as instances ? This may create problems when using billboards linked to a camera.

If not, please send us the scene to our support email (support@itoosoft.com) for checking .

Carlos Quintero
iToo Software

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3320
    • iToo Software
Re: Animation and Rotate
« Reply #2 on: September 07, 2010, 10:21:29 PM »
The problem was in the template objects used by Forest to create the billboards. By default, these objects are in a hidden and freezed layer, but by some reason they were modified in your scene.

How to fix it:

- Open the Layer Manager, and disable "Hide" and "Freeze" checkboxes of the layer "forest_templates"
- Select all "_forest_template" objects from the scene (use "Select by Name" tool)
- Delete the selected objects
- Save the scene, reset and reload
- Select any Forest object and modify some parameter to force a rebuild
Carlos Quintero
iToo Software