Itoo Software Forum

Author Topic: Area mode "edge" not affecting paint areas together with surface area turned off  (Read 539 times)

thefox

  • Newbie
  • *
  • Posts: 49
Hey,

I was always wondering why "my" edge mode settings we're not working as intended - and now I see why.. ..kind of.

If I use FP (library preset in this case) on a surface ONLY it does work properly, overlapping elements are cut. Perfect.
On large surfaces I normally turn off the surface and add several paint areas, set to include.

Works perfectly - except the edge mode: clumps are still overlapping the surface edge - please see image attached.
The paint area boundary is perfectly cut, only the surface edge elements remains uncut.. ..if it was vice versa it wouldn't bother that much (maybe later in some other case it would).

It does not make a difference if I switch off the surface and draw "include" paint areas or if I leave the surface switched on, draw a complete "exclude" area over the whole surface (doesn't make much sense, just for testing purpose here) and drawing another "include" on top - same problem.

It ONLY works with surface set to "on", a paint area covering the whole surface set to "exclude" and some parts of this area erased to revert the elements.
I'm a little confused as this does not seem to make much sense to me - but probably I did something wrong (I hope).. :)

Kind regards
Niko

PS: The images have some christmas feel, needs just some red balls in the green circle..
« Last Edit: December 02, 2015, 06:53:20 PM by thefox »

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1547
Hi Niko,

When the Surface Area isn't used for distribution, it doesn't have any influence over features like the Falloff (Density / Scale), Boundary Checking etc. Being turned off, the Surface Area is used just to define the scattered item's position on the Z axis.

Hope that clears it up.

Best regards,

thefox

  • Newbie
  • *
  • Posts: 49
Michal,

tanks, yes, it does and I was expecting this after the tests I did.

It's a little uncomfortable to paint a full exclude area over the surface before adding include areas - if thats the correct way to start then. (Well, I guess it's not :) )
And it does still not work with those include paint areas afterwards - seems like this way is disabling the surface edge "edge" mode (as it still works on the paint area edges ON the surface).

In reverse: what would be the correct way of scattering objects over a surface by using all kinds (exclude object, in/exclude spline, in/exclude paint area, exclude FP object) in several places AND keeping the "edge" mode working on the surface edges?

The only guess I have is to erase the painted exclude area where objects are meeting the surface edges - and to add several kinds of in/exclude parts in all other areas on the surface.
Am I right?
 

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1547
Hi Niko,

I would suggest also another workaround:

- Convert your Paint Area into Spine Area.
- Extract a "boundary spline" from your surface (using Edit Edges -> Create Shape). Please check this "Edges of Surface Areas" related post for more details.
- Attach those two splines together and apply the Boolean - Intersection operation. (attaching screenshot)

This way you'll get a Spline Area with precisely defined edge corresponding with the surface.

Hope you'll find this workaround helpful.

Best regards,