Itoo Software Forum

Author Topic: Bug with "Select models" after copy/paste in "Geometry"  (Read 465 times)

BH4030

  • Newbie
  • *
  • Posts: 8
Bug with "Select models" after copy/paste in "Geometry"
« on: September 17, 2015, 04:21:45 PM »
Greetings!

Found a bug. Can not chose models for my include area with "Select models" "Pick" button. They simply stay disabled if I click "Pick" again. It happens with objects (in my case with template 2D planes) that had their settings copy-pasted, in "Geometry" rollout. Perhaps some internal ID is also copy-pasted and FP does not sees them as different objects?

I have an enormous amount of 2D planes with texture variations in FPs to simulate crowd an other stuff, and all with copy-pasted settings, is there any workaround, without building new FPs from the scratch?

Scene attached.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3158
    • iToo Software
Re: Bug with "Select models" after copy/paste in "Geometry"
« Reply #1 on: September 17, 2015, 05:28:36 PM »
Hi, you are right. It's a bug not reported until now.
Copy/Paste is duplicating IDs, while they should be unique. I've added the bug to our to-do list, it will be fixed in the next update.

Until then, please use the attached script. It rebuilds IDs for the selected objects. After applying it, reassign "Select Spec" in your areas if needed.

I hope that helps.
Carlos Quintero
iToo Software

BH4030

  • Newbie
  • *
  • Posts: 8
Re: Bug with "Select models" after copy/paste in "Geometry"
« Reply #2 on: September 17, 2015, 05:46:42 PM »
Thank you, will try this script.