Itoo Software Forum

Author Topic: edge mode in vray 6 gpu  (Read 2736 times)


  • Full Member
  • ***
  • Posts: 107
edge mode in vray 6 gpu
« on: May 10, 2024, 09:11:23 PM »
i'm getting an error in vray 6, update 2.1 (6.20.06 build 00000) and forestPro

i'm loading a preset lawn, layered lawn, or autumn leaves and applying it to a circle spline with a hole in it and an edit poly modifier.

when i switch from point mode to size mode, it works just fine and i see it update in my viewport.

when i switch to edge mode, i get an error that say "Edge mode is not supported for the current render. See documentation for details. point mode will be used instead"

now, i opened a scene from about 6 months ago (created in an earlier version of vray and forestpro) and those rendered just fine, i confirmed the grass were set to edge mode.

i have been using Vray GPU in RTX mode for just over a year now.  The video card drivers are appropriate for Vray GPU, sometimes they lag behind a version or two.

I switched my Vray GPU to CUDA mode, started an IPR render while in Point mode for the forest object, then i stopped the IPR and switched to edge mode and the error went away and it was working.

Finally, i stopped all IPR rendering, switched back to RTX mode, and switched between Point - Size - Edge mode and got no errors.  The edge mode even worked as expected.  Oh and I also switched to one of the Large gravel presets having deleted all the leaves in the Geometry rollout, clicking on library and imported a Large gravel preset.

so this is all very interesting.  thanks.


  • Full Member
  • ***
  • Posts: 107
Re: edge mode in vray 6 gpu
« Reply #1 on: May 10, 2024, 10:02:31 PM »
huh.  so i was using a test scene with a circle edit spline offset like a donut and edit poly on it as my surface.  still getting that error.

i went into the scene i was working on when i noticed this problem.  not only did i get the error that edge mode was not supported, but 3ds max would completely lock up on me.

i noticed that the flat surface i was using to distribute one of the grass presets(which came from Revit) had thickness to it.  i deleted all polygons except for the top - nice and flat too.  i isolated just the newly modified surface and the forestpro object, hit render in point mode, then switched to edge mode and this time no error, no lock ups and edge mode worked as expected.  all while in RTX mode.

so the original scene is working just fine which is great.  not sure why a completely new scene (the donut one) was a problem. i had closed max and re-opened it to create the new test scene.  i will give that a try.

it makes sense that edge mode would freak out on a solid object with top/bottom/sides.