Itoo Software Forum

Author Topic: CPU not reaching 100% usage with forest pack when rendering  (Read 1473 times)

bimmer88

  • Newbie
  • *
  • Posts: 4
CPU not reaching 100% usage with forest pack when rendering
« on: February 05, 2014, 05:24:34 PM »
Hi,

I'm experiencing very low CPU usage when rendering a scene with forest grass and custom objects scattered. Once before hand with no forest the system uses 100% CPU. the highest the CPU reaches is 50ish % then stays between 6% and 13%

Multi core is set to affinity and hyper treading is enabled in 3d max and BIOS.  See attached screen shot.

Is there a reason why this happening and how do i prevent it low CPU usage?

Thanks Will

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3156
    • iToo Software
Re: CPU not reaching 100% usage with forest pack when rendering
« Reply #1 on: February 06, 2014, 12:04:28 PM »
Not all rendering process are multi-thread. In this case, as far as i see in your screenshot, Mental Ray is in the "Translating scene" stage, which is a single thread-process (it sends the scattered items to the render engine).

Anyway, this step should be almost inmediate, even in complex scenes. For example, the final scene of the Modern Barn tutorial doesn't take more than one second in my computer (i980x, Max 2014, FP 4.1.5).

Please check if there is some huge Forest object in your scene (you can use Forest Stats to see the estimated number of render items). What Max and Forest version do you use ?
Carlos Quintero
iToo Software

bimmer88

  • Newbie
  • *
  • Posts: 4
Re: CPU not reaching 100% usage with forest pack when rendering
« Reply #2 on: February 06, 2014, 06:24:19 PM »
Hi Carlos,

Yea after i sent the post i tested the barn scene to see if something else was up but mine does the translating within a second or two. In this scene takes ages to do this. pc specs are 2 xeons E5620 @2.4GHz, 24 RAM. Studio Max 2014 service pack 3 and FP 4.1.5.


I ve included screen shots of all the grass areas, hedges and stone areas showing their stats. i wasn't able to put to grass all on one forest element as the spline z height varies between and FP pack shows the grass on one level and not the other, hence separate areas.   how do you know if one of the forests stats is huge or not?

bimmer88

  • Newbie
  • *
  • Posts: 4
Re: CPU not reaching 100% usage with forest pack when rendering
« Reply #3 on: February 06, 2014, 06:25:44 PM »
here are some others. would you be able to point out which stat is causing the issue?

Thanks

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3156
    • iToo Software
Re: CPU not reaching 100% usage with forest pack when rendering
« Reply #4 on: February 07, 2014, 09:13:08 AM »
Forest020 is causing the delay: the number of render items is 1.7 mill, that is a lot for Mental Ray. Also this value is estimated, total value may be slightly greater.

From our experience, rendering times may grow exponentially above 500k items (including all Forest objects).
Note: this is a limitation exclusive of Mental Ray. You can find more information in the Rendering Best Practices guide.

In this case, you may cut down the number of items applying techniques as Camera Clipping, Camera Falloff or modifying the density of the object.
Carlos Quintero
iToo Software