Itoo Software Forum

Author Topic: Crash after importing an already imported object from library  (Read 77 times)

GC1591

  • Newbie
  • *
  • Posts: 3
Crash after importing an already imported object from library
« on: September 19, 2019, 11:10:39 AM »
I'm using 3Ds Max 2014 and ForestPack 6.2.2 (although it was also the case in previous versions, as far as I can remember).
When I import objects from a library (as xRefs, using materials from the scene), ex. a few different trees (in this case from maxtree library) everything's fine. However, when I create a new forest object and import a tree that already exists in the scene, 3Ds Max either freezes or crashes.
For example, in the first forest object, I open the library and import tree1, tree2, tree3. Then I create another forest object, open the library and import tree 4, tree 5, tree 6. Everything works fine. But, if instead of importing tree 4, tree 5, tree 6, I import tree 4, tree 5 and tree 3 (which has been already imported in the first forest object - as xRef), the scene crashes.
I hope my explanation is clear ;).
I found a workaround for this - I copy the previous object and attach the contents to the new one. It works, but it's not very efficient, especially when working with bigger scenes with several forest objects, where it's hard to keep track of every tree in the scene.
Is that a bug (that can be fixed, hopefully)? Or, if it can't be fixed for some reason, do you have a suggestion for a better workaround?
Thanks in advance!

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1688
Re: Crash after importing an already imported object from library
« Reply #1 on: September 19, 2019, 04:25:52 PM »
Hi,

Big thanks for reporting it - with your help, we've been able to reproduce this unwanted behaviour here too - it has to be investigated more in deep by our main developers. Once again, thanks for your feedback, it's very important for us.

Best regards,