Itoo Software Forum

Author Topic: BUG Report for greenwalls v6.0.3 preset "Grape Ivy | XY "  (Read 135 times)

SU1130

  • Newbie
  • *
  • Posts: 5
BUG Report for greenwalls v6.0.3 preset "Grape Ivy | XY "
« on: November 26, 2020, 12:22:33 PM »
Hi!
I noticed that there is a bug in the "Grape Ivy | XY " template.
When trying to use this template you get an error that the object can't be found, but it lists the object description "A plant from the genus... " as object name.
Looking into the in the index.xml file of the vertical forests the contents of <description> and <object> are switched for the  "Grape Ivy | XY " template, which creates the error above.
I already tried redownloading the template but the error persists so I think nobody else noticed yet.

So to fix this in the index.xml of the vertical templates
line 106-116 should be this:
   <item class="maxobject">
      <name lang="english">Grape Ivy | XY </name>
      <name lang="latin">Grape Ivy | XY </name>
      <family/>
      <description>A plant from the genus lianas (woody vines) in the grape family. The majority are to be found in the tropics. This preset uses the XY axes of the Forest Object for distribution.</description>
      <bitmap>grapeIvy.jpg</bitmap>
      <maxfile>objects\_fp_greenWall1.max</maxfile>
      <object>fp_greenwall_surface_distribution</object>
      <matlib>matlibs\fp_green_wall_$(RENDERER).mat</matlib>
      <available>PRO</available>
   </item>

Manually changing the index.xml section to the above will make the template work.
Please fix and update this for all users.
Cheers
Christian

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 3275
    • iToo
Re: BUG Report for greenwalls v6.0.3 preset "Grape Ivy | XY "
« Reply #1 on: November 26, 2020, 12:25:04 PM »
Hi
Thanks for reporting.
We plan to fix all pending updates really soon.

Rokas
iToo Software

SU1130

  • Newbie
  • *
  • Posts: 5
Re: BUG Report for greenwalls v6.0.3 preset "Grape Ivy | XY "
« Reply #2 on: November 26, 2020, 12:26:51 PM »
No Problem
 Just noticed the contents of object was also wrong it should be "fp_greenwall_xy_grape_ivy" of course.
correct xml section is below
   <item class="maxobject">
      <name lang="english">Grape Ivy | XY </name>
      <name lang="latin">Grape Ivy | XY </name>
      <family/>
      <description>A plant from the genus lianas (woody vines) in the grape family. The majority are to be found in the tropics. This preset uses the XY axes of the Forest Object for distribution.</description>
      <bitmap>grapeIvy.jpg</bitmap>
      <maxfile>objects\_fp_greenWall1.max</maxfile>
      <object>fp_greenwall_xy_grape_ivy</object>
      <matlib>matlibs\fp_green_wall_$(RENDERER).mat</matlib>
      <available>PRO</available>
   </item>