Itoo Software Forum

Author Topic: Density issues distributing on surface  (Read 3019 times)

BU1662

  • Newbie
  • *
  • Posts: 6
Density issues distributing on surface
« on: May 23, 2011, 12:45:50 PM »
Hi
I need to build a big grassball, with grass going all around the ball.
I built it using a circle spline, and sphere as surface and using UV mode in surface.
It works fine, however it seems that the distribution is more dense in the centre of the circle spline than on the outside (please see attached jpg) - this makes sense to me because of the sloped surface, but would there be a way to fix this, ie have the distibution/density even across the ball?
Thanks

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3158
    • iToo Software
Re: Density issues distributing on surface
« Reply #1 on: May 24, 2011, 06:39:39 PM »

Hi, i'm sorry by the delay in replying, but we have not received the forum notification for your post.

Replying to your question, the problem here is the spherical UV mapping, which has not the same scale along the sphere. You can see how the UV coordinates are deformed using a Checker map.

I've been running some tests, and i got the best results with these parameters:

Distribution map Full
Collisions on, radius 50%
Transform Translation X: 20%, Y: 20%
Transform Rotation: Z: 0 to 359º

You can also try applying a box mapping instead the spherical one. The geospheres seem to generate a more uniform result as well.

Carlos Quintero
iToo Software

BU1662

  • Newbie
  • *
  • Posts: 6
Re: Density issues distributing on surface
« Reply #2 on: May 24, 2011, 06:46:37 PM »
Great, thanks very much

BU1662

  • Newbie
  • *
  • Posts: 6
Re: Density issues distributing on surface
« Reply #3 on: June 03, 2011, 07:14:27 PM »
I would also like to ask, how do the uv's work when using forest on a surface.  It doesn't seem to work properly while using this same sphere.
For example if I put a black and white map of the world in 'Map' under distribution map, it seems to tile the map 4 or 5 times.
In the attached jpg, I put another sphere next to it, mapped with same black and white map on diffuse to show what I would like to achieve with the distribution map on forest.
Ive put a UVW map modifier on the sphere and the forest but it makes no difference.
I've read the reference files and tried to find an answer searching the forums - it seems that the "Get UV's from surface" have been removed with the beta - but this seems to be exactly what I need?
Is there a solution?
Thanks

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3158
    • iToo Software
Re: Density issues distributing on surface
« Reply #4 on: June 03, 2011, 08:20:19 PM »
Is should work with the default parameters. Are you using the map channel 1 ?

The "Get UV's from surface" parameter has been removed because now it is always on by default. For Surfaces on UV mode, the map channel 1 is used. For Surfaces on XY mode, the channel must be defined in Distribution Map->Map channel.

(i just realized that the online reference was not updated about this parameter. I have updated it)

PD: you can remove the Area spline, it is ignored when using Surfaces on UV mode.

Carlos Quintero
iToo Software

BU1662

  • Newbie
  • *
  • Posts: 6
Re: Density issues distributing on surface
« Reply #5 on: June 04, 2011, 05:40:10 PM »
Thank you very much.
I saw now that it is working fine.
The big problem was that my 'update surfaces data' was not on auto so I could not understand why when I change the UVW map modifier on the sphere nothing happened to the forest.
As a note, I can't seem to change the 'map channel' in 'distribution map'.  It is currently at 0, but it is working fine so I am not worried.
Thanks

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3158
    • iToo Software
Re: Density issues distributing on surface
« Reply #6 on: June 04, 2011, 06:39:31 PM »

Yes, by default the surface data is not updated automatically. Forest builds an internal table with the terrain characteristics to optimize the speed of tree placement, and the automatic update of this table would be slow for large terrains.

The map channel cannot be changed because it is locked to 1 when using surfaces on UV mode.

Carlos Quintero
iToo Software