Itoo Software Forum

Author Topic: Density of grass  (Read 1721 times)

NK4773

  • Newbie
  • *
  • Posts: 9
Density of grass
« on: December 06, 2012, 11:33:37 PM »
I am new user of Forest Pro. I have applied Forest Pro to a surface and applied a custom map to define where my grass goes on the surface. That works perfectly, but I am not getting the density. I adjust Density Units, Pixels, Threshold with no success. It seems to put all the plants in rows and it seems like it cycles the rows in width but it never becomes close enough to make it look full. Sometimes they go completely away? What am I missing? Thanks in advance!
Using 3dsmax 2013  64 and latest version of forest pro.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3156
    • iToo Software
Re: Density of grass
« Reply #1 on: December 07, 2012, 09:42:37 AM »

Since this is a common question, i just added it to the Forest FAQ. Please, see my reply there.

Carlos Quintero
iToo Software

suppenhuhn

  • Jr. Member
  • **
  • Posts: 67
Re: Density of grass
« Reply #2 on: October 28, 2014, 05:16:05 PM »
Hi,

just have the same thing - in this tutorial there is one point:

To avoid the grid effect created by the Full map, set random Translation to 10%.


But i can't find this random translation setting - is it only available in older Forest Pro versions ?

Rokas

  • Sr. Member
  • ****
  • Posts: 424
Re: Density of grass
« Reply #3 on: October 28, 2014, 05:30:29 PM »
It is the very first checkbox after you expand this rollout:

xpp_nd_ruphus

  • Newbie
  • *
  • Posts: 10
    • Portfolio
Re: Density of grass
« Reply #4 on: November 10, 2014, 06:10:53 PM »
i tried method discribed in dense grass tutorial, but its not working in 4.3.0b, main forest object not scatter anything, if i try to put forest object inside main forest object, with normal geometry works ok, i tried with surfaces and splines, but same result

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1485
Re: Density of grass
« Reply #5 on: November 11, 2014, 11:29:14 AM »
Hi,

Would you please provide us some more details about the issue? Which 3ds Max version and renderer are you using? Thanks in advance.

Also, please try to set the inner Forest object: Display->Render->Mode from Automatic to Meshes (if not set so).

Kind regards,

xpp_nd_ruphus

  • Newbie
  • *
  • Posts: 10
    • Portfolio
Re: Density of grass
« Reply #6 on: November 11, 2014, 12:10:01 PM »
i found the exact problem, when i copy forest object (to save all settings and object list) and change scattering spline area to make patch, in main forest object i put copied forest, and forest scatters object outside spline area

But if i create new forest for patch all works correct

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1485
Re: Density of grass
« Reply #7 on: November 11, 2014, 05:17:59 PM »
Hi,

Please double check the Camera rollout in copied Forest object - most probably is out of its visibility limits. You can Clear actual camera assignment and that should fix your issue.

Kind regards,

xpp_nd_ruphus

  • Newbie
  • *
  • Posts: 10
    • Portfolio
Re: Density of grass
« Reply #8 on: November 11, 2014, 05:32:45 PM »
already did it, and no camera in this test scene, as you can see on screenshot forest works, and scatters objects in correct area, but moved away from spline

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1485
Re: Density of grass
« Reply #9 on: November 11, 2014, 05:53:20 PM »
Hi,

While cloning - did you make a Copy or Instance? Forest objects shouldn't be instanced. If you cloned it as an Instance, please Make it unique and that should solve it.

If the issue persist, would you please send us your scene to support@itoosoft.com? For large files, please use a web sharing service as WeTransfer. Thanks in advance.

Kind regards,