Itoo Software Forum

Author Topic: Edge cut similar as the preview  (Read 643 times)

raistlin

  • Newbie
  • *
  • Posts: 33
    • My website
Edge cut similar as the preview
« on: September 05, 2017, 12:45:35 AM »
Hi !
Is there a way to trim the VrayProxies like the preview does?
When i preview in the viewport (with the control + clic option) i have a preview which is really nice and clean, but it's absolutly not the same thing as the render does...
So, my question is simple as i said... IS there a way to cut it cleaner than the preview?

Thx
La vie est une aventure dangereuse d'où personne n'est jamais sortie vivant.

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1547
Re: Edge cut similar as the preview
« Reply #1 on: September 05, 2017, 10:44:36 AM »
Hi,

I'm afraid, that as mentioned in our on-line reference guide: "Please be aware that Edge Mode is not compatible with V-Ray proxies. If you wish to reduce file sizes and use Edge Mode it is recommended to use XRef objects instead."

Please feel free to check the following FAQ post "Should I use meshes or proxies with Forest in V-Ray?" for a brief list of pros and cons between meshes / proxies (internally all items are converted to native V-Ray's instances).

Also, it's always possible to use the work-flow explained in the "Grass Edges" tutorial (mixing small / large clumps).

Best regards,

raistlin

  • Newbie
  • *
  • Posts: 33
    • My website
Re: Edge cut similar as the preview
« Reply #2 on: September 05, 2017, 12:09:36 PM »
Thx, I'll try to replace Proxys by Xref objects, no problem at all on that, BUT...
If i try XREF, does the edge cut work fine?

I let you imagine that i'm trying to do a very large and optimisez cool grass pattern, for an heavy scene... And i've prohibited rendertime...
So, if you have another trick to do that for animation (Forest LOD isn't possible, because the LOD don't work really smart with large grass area...

Cheers, I'll be back after i've test Xref Cut...
La vie est une aventure dangereuse d'où personne n'est jamais sortie vivant.

raistlin

  • Newbie
  • *
  • Posts: 33
    • My website
Re: Edge cut similar as the preview
« Reply #3 on: September 07, 2017, 09:30:47 AM »
OK!

It work fine with some little patterns, i've tried to make some 2m² grass patch but the trimming in't really clean as he is in the preview, but with 50cm² it do the job...
I've notice this is also because the z minimum position is quote to cut or not, and if we have some large geometry pattern, it doesn't follow a fine surface, and we have "flying part of the pattern"...
So... for reallllllllyy large surface and Grass i've tried the LOD (this is also why i'm quoting later) and it doesn't work fine if you fly perpendicular to the surface, because light pattern doesn't cover really well the surface where he is scattered...


And if i put the geomety to 100 millions... my memory satured...

If you know a way to optimise that (please i'm sure you probably answered to use mapping and texture for far shot but... tchnically it's not the answer i'm waiting for... :)

thanks
La vie est une aventure dangereuse d'où personne n'est jamais sortie vivant.

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1547
Re: Edge cut similar as the preview
« Reply #4 on: September 07, 2017, 12:40:14 PM »
Hi,
Quote

"'... tried to make some 2m² grass patch but the trimming in't really clean as he is in the preview ..."
The Edge Boundary Checking is removing elements within one item that are "based out of area used for distribution" - having any "overhanging faces" under one element, these will be fully removed or not, depending if the element is based inside/outside of the distribution area.

If any gaps appear, a recommendable way to fix these areas would be to adjust Distribution Map settings - Density or Offset X / Y values. That should fix it (as shown on attached screen-shots).

As mentioned above, there is no "physical cut" performed while using the Edge Boundary Checking mode (as this would be extremely resource demanding). This "trimmed part" is treated by the render engine as a kind of "Matte object" internally (this way render engine ignores it for its calculations).
Quote
"it doesn't follow a fine surface, and we have "flying part of the pattern""
I would suggest you to check the Direction settings under the Surface tab (probably is set to 100). In case of large clumps I would recommend you to set it to Surface's Normal (0). Specially for these purposes, you can take advantage of Scale to fit sloped area option. You can find more about these setting in our on-line reference guide.

Best regards,