Itoo Software Forum

Author Topic: Edge mode after large Translation values  (Read 1360 times)

Kostas

  • Newbie
  • *
  • Posts: 8
Edge mode after large Translation values
« on: November 13, 2016, 11:58:07 AM »
Hi all,

Haven't found something after a quick search (If it's already answered sorry for the double post). I get this issue when using large translation values in the Transforms. The scattered objects go beyond the edges and inside the neighboring areas. It doesn't help to use point or size or edge in Boundary Checking. It seems that the order it operates is first it uses the Boundary Checking and then it makes all transforms. Am i missing a checkbox or an option...?

Thanks

Kostas

  • Newbie
  • *
  • Posts: 8
Re: Edge mode after large Translation values
« Reply #1 on: November 13, 2016, 12:37:17 PM »
Hi again,

To answer my own question  :D
I did a better search and I got this : http://forum.itoosoft.com/index.php?topic=2773.msg10583#msg10583
Is this going to be worked on in an updated release? Sometimes I use large values in translation >100...

Kind regards,


Kostas

  • Newbie
  • *
  • Posts: 8
Re: Edge mode after large Translation values
« Reply #2 on: November 14, 2016, 02:11:21 PM »
This is happening with translation values -50% to 20% in both X and Y. In boundary checking I use size to make sure that nothing is near the edge but it seems that it's not capable of eliminating the phenomenon. It seems that it would work only with very low values.

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1736
Re: Edge mode after large Translation values
« Reply #3 on: November 14, 2016, 03:30:47 PM »
Hi,

An possible way to avoid this kind of problems, where enabled Transform - Translation can push some items outside of the Area, would be to "limit" these values in proximate areas to the boundary line. Please feel free to try attached "transalteFalloff.eff" Effect, which is interpolating these values in problematic zones - the attached sample is actually working just on Include Spline Areas.

Anyway, values mentioned in your last post shouldn't lead to items outside of the distribution area. Would you mind to send us your scene (ideally a simplified version of it) to check it here? Thanks in advance.

Best regards,

Kostas

  • Newbie
  • *
  • Posts: 8
Re: Edge mode after large Translation values
« Reply #4 on: November 16, 2016, 11:00:10 PM »
Hi Michal,

Sorry for the late reply. I'm trying to wrap the project up and deliver. I wouldn't mind sending you the scene, but I've changed it completely (plants and settings). I'll try to reproduce after I finish the project so I can test the effects file and also send you the file for you to check.

Kind regards,

MrpepeLepeu

  • Newbie
  • *
  • Posts: 28
Re: Edge mode after large Translation values
« Reply #5 on: November 27, 2019, 04:01:36 PM »
Is there a different solution to this?
I have the same issue: using translation takes objects outside of the boundary.
If I try to use edge mode I get this:
"edge mode requires to use forest edge on the opacity slot of all materials but some of them..."

MrpepeLepeu

  • Newbie
  • *
  • Posts: 28
Re: Edge mode after large Translation values
« Reply #6 on: November 27, 2019, 10:43:31 PM »
Anyone?

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2514
    • iToo
Re: Edge mode after large Translation values
« Reply #7 on: November 28, 2019, 09:19:29 AM »
Hi I am not sure I understand Your problem. What renderer do You use? Have You set up Your opacity maps? What translation values are You using?

It would help to have Your max file scene.
Rokas
iToo Software

MrpepeLepeu

  • Newbie
  • *
  • Posts: 28
Re: Edge mode after large Translation values
« Reply #8 on: November 28, 2019, 03:31:28 PM »
What the OP said: "I get this issue when using large translation values in the Transforms. The scattered objects go beyond the edges and inside the neighboring areas. It doesn't help to use point or size or edge in Boundary Checking."

When using large translation values the objects move beyond the boundary.

I use corona, but this is visible on the viewport.

"What translation values are You using?": over 100. Still, shouldn't the boundary be the cutoff?
"Have You set up Your opacity maps?" I'm not sure what you mean. Opacity maps on the object itself? Yes. That's all fine.

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2514
    • iToo
Re: Edge mode after large Translation values
« Reply #9 on: November 28, 2019, 03:37:02 PM »
OK, with large translation values then there is no option to fix overhanging geometry. As a workaround You can hide those with Render Time booleans.

Example in this thread.
Detailed guide how to set it up in this thread.

Hope this helps.
Rokas
iToo Software