Itoo Software Forum

Author Topic: Element variation not working correctly  (Read 468 times)

iainbanks

  • Newbie
  • *
  • Posts: 10
Element variation not working correctly
« on: June 13, 2016, 01:23:43 PM »
Hi, i have a simple scenario where i have a checker board material applied to the surface plane.  I've created a simple object with different elements as the forest geometry. 

The material applied to the forest has a simple forest color in the diffuse with override turned on, 'get color from map' on and 'as texture on surface' on.  Variation is set on element and blending mode on normal.

So with these settings im expecting to see that when the element of the object crossed the checker board edge it should take the colour of its position on the checker board (either black or white) However the result im getting is that the whole object including all of its elements is taking on a single colour regardless of where the element sits. Its possibly using the origin point of the object to apply the color across all elements.

Is there something i'm doing wrong here?  Any buttons i forget to check?

Max: 2016 64 bit
windows 10 64
FP 5.0.5

Thanks

I

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3156
    • iToo Software
Re: Element variation not working correctly
« Reply #1 on: June 13, 2016, 01:42:48 PM »
Hi, this is a limitation of "Get color from map": it doesn't work at element level, only by item. We tried several workarounds for that, but didn't get the result we need.

The only way is to use smaller objects, with  Tint by Item.
Carlos Quintero
iToo Software

iainbanks

  • Newbie
  • *
  • Posts: 10
Re: Element variation not working correctly
« Reply #2 on: June 13, 2016, 01:56:59 PM »
Hi, thanks for your response.

Couldn't the Fp have a button / option to use the uvw map from the surface to project the texture map down onto it?  Its a sort of work around but would work for the carpet that im trying to create.

Iain

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3156
    • iToo Software
Re: Element variation not working correctly
« Reply #3 on: June 13, 2016, 05:30:05 PM »
I just remember a similar case... Please, take a look to this post. It describes a trick to map the texture over the Forest object, without having to modify UVs.
« Last Edit: June 13, 2016, 05:34:09 PM by iToo »
Carlos Quintero
iToo Software