Itoo Software Forum

Author Topic: Evermotion library problem  (Read 2035 times)

ajvar

  • Newbie
  • *
  • Posts: 4
Evermotion library problem
« on: June 10, 2015, 12:49:12 PM »
Hi,

I've installed evermotion catalog and tried to set instalation path as shown in the hqplants example. I've bought evermotion pack 126 and 106 few months ago but i cant make the connection with forestpro. I'm navigating to that evermotion folder and get this message: "The selected directory doesn't contain Evermotion Plants AM106 library."


Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1475
Re: Evermotion library problem
« Reply #1 on: June 10, 2015, 03:15:11 PM »
Hi,

The Library Browser (with Evermotion Catalog add-on istalled) is looking for the "original folder structure" after unpacking. Please unpack all assets (textures & models) with their original folder names into one "parent folder" (maybe that could lead to these troubles as their models are delivered "by folder"). Than you should map the "parent folder" - containing Textures (maps) folder and your renderer's folder with models (Vray, MentalRay, ScanLine). Also please note, you shouldn't rename these folders (as our add-on uses that original folder names to allocate corresponding .max files for selected renderer).

As our "installation checker" is looking for the first MentalRay model file, the "MentalRay" folder should be unpacked also. Could be, that you didn't unpack that folder? If so, please unpack it (also in case you'll be not using this renderer).

Than, when EvermotionPlants Libraries pop-up window asks you to Select Installation Path you should select the path to whole folder structure (not where corresponding models or textures are located). It should be the folder where you have extracted all these assets (including Textures (maps), MentalRay, Vray and ScanLine folders).

It´s strongly recommended to include the Textures (maos) folder into your User Paths. This way, bitmaps are always found when loading or importing models from the library. The path to your location of used assets should be added to the 3ds Max configuration by using Customize - Configure User Paths - External files.

Best regards,
« Last Edit: June 10, 2015, 03:17:08 PM by Michal Karmazín »

MH4288

  • Jr. Member
  • **
  • Posts: 63
Re: Evermotion library problem
« Reply #2 on: June 12, 2015, 03:10:55 PM »
I have same problem but cant get it to work :-(

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1475
Re: Evermotion library problem
« Reply #3 on: June 12, 2015, 04:02:31 PM »
Hi,

Would you please specify the Evermotion's Archmodels volume you are facing troubles with? By following steps described above it should work fine (remember the MentalRay folder should be extracted also even it'll be not used and you should select the "upper" folder). Thanks in advance.

Best regards,

MH4288

  • Jr. Member
  • **
  • Posts: 63
Re: Evermotion library problem
« Reply #4 on: June 12, 2015, 04:50:31 PM »
Archmodels 136. I download only VRay files, so I dont have mentalray. Files are pretty big in some cases so I dont want to download and have on my HDD files I will never use.

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1475
Re: Evermotion library problem
« Reply #5 on: June 12, 2015, 05:04:18 PM »
Hi,

Well, in that case, it's possible to cheat the installation checker by editing the evermotionplants.ms file. It's by default located at C:\Program Files (x86)\Itoo Software\Evermotion Catalog\lib.

On the top, where the evermotiondef global variable is defined, you may manually change the "check path" for the Archmodels 136 in a following way:

#("AM136", "Evermotion Plants AM136", "\Vray\001_v1_*.max", "")

That should fix it for "V-Ray only" use. Hope that helps.

Best regards,

ajvar

  • Newbie
  • *
  • Posts: 4
Re: Evermotion library problem
« Reply #6 on: June 12, 2015, 07:33:16 PM »
I dont have enough time these days so this Evermotion plugin is something i can live without but i was playing few minutes yesterday and today and still no result for the evermotion 126. I managed to solve evermotion 106 but with 126 still no sucess. I must be doing something wrong. I extracted everything from that evermotion pack, mentalray, scanline, vray, obj and so on, and still nothing. I noticed one difference between those packs. Evermotion 126 has a folder named "AM126_MENTALRAY" which is not mentioned in that evermotionplants.ms. Could that mean something? 

Best

Mario




MH4288

  • Jr. Member
  • **
  • Posts: 63
Re: Evermotion library problem
« Reply #7 on: June 12, 2015, 08:14:25 PM »
Thanks for fantastic support!! Now it works like a charm! Thanks a lot!

TL1895

  • Sr. Member
  • ****
  • Posts: 305
Re: Evermotion library problem
« Reply #8 on: June 13, 2015, 12:47:36 AM »
So, where does one find this evermotion catalog?  I've some of their collections and would like to try it...
Thanks!

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3151
    • iToo Software
Re: Evermotion library problem
« Reply #9 on: June 13, 2015, 08:50:03 AM »
So, where does one find this evermotion catalog?  I've some of their collections and would like to try it...
Thanks!

You can get it from the Downloads->Forest Pack section.
Carlos Quintero
iToo Software

ajvar

  • Newbie
  • *
  • Posts: 4
Re: Evermotion library problem
« Reply #10 on: June 13, 2015, 10:13:19 AM »
So archmodels 126 works for you? Please confirm.

Btw. you forgot to insert archmodels vol.117 in the list.

ajvar

  • Newbie
  • *
  • Posts: 4
Re: Evermotion library problem
« Reply #11 on: June 13, 2015, 11:47:24 AM »
Ok, I fixed it. Just had to rename some folders (even though you told me not to - not the best advice but nevermind).

Any future problems with vol 126. - to other users - please rename folders.

Anyway, thanks.

BE4139

  • Newbie
  • *
  • Posts: 3
    • dimension3+
Re: Evermotion library problem
« Reply #12 on: June 15, 2015, 04:11:48 PM »
I only have the vray max files unpacked and edited the evermotionplants.ms script and got vol. 126 to work properly.

I wish you would include Archmodels vol. 154 in your Evermotion library, this is a really good one.

Thanks

dimension3plus.de

TL1895

  • Sr. Member
  • ****
  • Posts: 305
Re: Evermotion library problem
« Reply #13 on: July 02, 2015, 01:35:47 PM »
So, it worked for me, but then I purchased v154, and cannot get it to appear.  It's located exactly where the other ones are with original names, etc.

TL1895

  • Sr. Member
  • ****
  • Posts: 305
Re: Evermotion library problem
« Reply #14 on: July 02, 2015, 01:47:37 PM »
...also, could there be an option for vray only.  I also don't want to have to download and extract those mental  ray packs.
I also don't want to have to edit the .ms file, ever, lol.

Thanks,
TL1895