Itoo Software Forum

Author Topic: exclude areas strange behavior.  (Read 1664 times)

lukx

  • Full Member
  • ***
  • Posts: 115
    • lukxCGI
exclude areas strange behavior.
« on: April 19, 2013, 02:16:48 PM »
I'm not sure why but when used with preset grass it's not excluding right. For exampel here I but pavewalk and curb to be excluding object and still pieces of grass is penetrating it.


iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3156
    • iToo Software
Re: exclude areas strange behavior.
« Reply #1 on: April 19, 2013, 05:08:33 PM »

Pease, try setting Areas->Boundary Checking to "Size", instead "Point". In this way, Forest uses the item's width and its collision radius for the area checking, instead only the position. Also be sure the pivot point of the custom object is centered.

Carlos Quintero
iToo Software

lukx

  • Full Member
  • ***
  • Posts: 115
    • lukxCGI
Re: exclude areas strange behavior.
« Reply #2 on: April 19, 2013, 08:42:23 PM »
but I'm using preset grass, how I can check it's pivot?

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3156
    • iToo Software
Re: exclude areas strange behavior.
« Reply #3 on: April 19, 2013, 10:48:46 PM »

In the presets the pivot is aligned correctly. Did you try the Boundary Checking option ?

Carlos Quintero
iToo Software

lukx

  • Full Member
  • ***
  • Posts: 115
    • lukxCGI
Re: exclude areas strange behavior.
« Reply #4 on: April 20, 2013, 08:22:27 PM »
Carlos boundary checking is grayed out for all my objects, I don't know why.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3156
    • iToo Software
Re: exclude areas strange behavior.
« Reply #5 on: April 21, 2013, 08:53:26 AM »

Probably you have only a Area Surface entry, but the Boundary option works only the the areas of type Spline. In this case, should be necessary to create one or several splines to define the grass limit.

Carlos Quintero
iToo Software