Itoo Software Forum

Author Topic: Forest pack 6.1 bitmap error  (Read 520 times)

EM3498

  • Newbie
  • *
  • Posts: 8
Forest pack 6.1 bitmap error
« on: June 18, 2018, 07:38:50 PM »
Hello
After upgrading to the latest version of Forest Pack (6.1) we got error message (bitmap manager error) during loading the project (screenshot in the attachment).
Plugin was installed according to this guide :
https://forum.itoosoft.com/faq/installing-forestpack-6-assets-in-a-shared-network-path/
We have 10 rendernodes, thats why the main forest library is on the network location.
As i noticed the forest distmaps aren't located in the network library folder. Distmaps are still in the forestpack installation folder, which is located in the local harddrive.
How to properly setup the forest&railclone plugins for multiple computers and rendernodes?
Isn't be better if the distmaps will be located in the same folder in the network as the library maps?
Shouldn't all of the assets used by the forest or railclone plugin be located in the same network place, which is accessible by all computers in that network?

Kind Regards
Greg

amitgedia

  • Jr. Member
  • **
  • Posts: 80
Re: Forest pack 6.1 bitmap error
« Reply #1 on: June 19, 2018, 08:38:15 AM »
Hi,
I got the same error message when i upgraded to FP 6 but then i changed the configure user paths in 3dsmax to "C:\Program Files\Itoo Software\Forest Pack Pro\distmaps\images" and then everything worked fine
I think previous versions of FPP was installed in Program Files x86 and the latest FPP gets installed in Program Files on the local drive so we have to reconfigure the paths for better use

I am not sure whether I helped with your issue or no but just wanted to share my experience as well

Thanks

RealViz

  • Newbie
  • *
  • Posts: 19
Re: Forest pack 6.1 bitmap error
« Reply #2 on: June 19, 2018, 08:43:33 AM »
It happend when upgrade from older FP. Because old path is "Program Files (86)" new is "Program Files". But FP dont change path in 3dsmax.ini. Its a bug. Its annoying to copy 3dsmax.ini on all render slaves :-(

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3359
    • iToo Software
Re: Forest pack 6.1 bitmap error
« Reply #3 on: June 21, 2018, 12:12:24 PM »
Hi, although bitmaps has been moved from C:\Program Files (x86)\Itoo Software\Forest Pack Pro\distmaps\images to C:\Program Files\..., Forest adds the new path in "Customize->External Files".
Therefore, Max should be able to find the bitmaps. Path is added in the render nodes as well.

We did several tests here, and everything seems correct.
Carlos Quintero
iToo Software

alexrecentspaces

  • Newbie
  • *
  • Posts: 27
  • Recent Spaces
    • recentspaces.com
Re: Forest pack 6.1 bitmap error
« Reply #4 on: July 10, 2018, 10:38:07 AM »
Hi Carlos,

Unfortunately your 6.11 installer isn't adding those custom user paths on some of our workstations. On some it does, on some it doesn't. Apart from manually adding all the paths (which is going to take a long time and error-prone) is there a solution to this?

Kind regards,

edit: manually adding C:\Users\USER\AppData\Local\Itoo Software\Forest Pack Pro path and checking "Add Subpaths" has fixed this. But it's very curious why your installer didn't update max's paths on 2 of our workstations but all the rest are fine. It has nothing to do with running the installer as an admin or not either, we tested that.
« Last Edit: July 10, 2018, 10:46:32 AM by alexrecentspaces »
Alex York
Recent Spaces

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1555
Re: Forest pack 6.1 bitmap error
« Reply #5 on: July 10, 2018, 12:53:44 PM »
Hi Alex,

Might be, the Do not show this message again checkbox has been marked previously to disable that pop-up window - you can revert it to its default value (to pop-up) by setting the checkTexturePaths = 1 in the forestpack.ini configuration file located by default at:

C:\Users\<username>\AppData\Local\Autodesk\3dsMax\<maxversion>\ENU\en-USregardsg

That should help.

Best regadrs,