Itoo Software Forum

Forest Pack => Forest Pro (*) => Topic started by: MJ4821 on October 09, 2013, 10:17:08 AM

Title: Forest Pack DR issues
Post by: MJ4821 on October 09, 2013, 10:17:08 AM
We've got a distinct issue with rendering Forest Pack items via VRay DR and have been browsing other topics in the hope that we can find the issue. Unfortuantely that doesn't seem to be the case hence this new topic.

In short, the problem that we are experiencing is that the host machine (the one which the file is being worked on) renders a different forest to that of the nodes, as illustrated in the first image; the second image shows what is rendered by the host machine on its own while the third illustrates what is rendered by the nodes, a clear difference can be seen.

We have tried various tricks and tweaks to try and resolve this, including rendering the irradiance and light cache maps on the local machine and then specifying them to be used. This did not work. We have also rendering via DR with one node at a time (we have three in total) to see if one was the root cause. All nodes recreated the error. Subsequent to that we sent individual renders of the scene to each node via Backburner, the result of which was that each node rendered the image perfectly and identically. We also sent the image with DR (using all three nodes but not the host machine) via Backburner and the image again rendered perfectly.

We have also checked the camera for clipping planes and near/far ranges and can confirm that there is no clipping and changing the near/fear ranges does nothing to resolve the situation; the "Hide Custom Objects..." box is unticked and the max items is set to 1,000,000. Additionally unticking "Use DirectX acceleration" does nothing to assist.

For further information on out setup and resources, please see below:

Although we have a viable workaround by way of sending images to render through Backburner and only using the host machine for modelling it falls over on account of us not being able to accurately monitor the image as it is processing which does cost us time.

Any assistance would be massively appreciated.
Title: Re: Forest Pack DR issues
Post by: iToo on October 09, 2013, 11:19:43 AM
For some reason the host machine is generating a different Forest distribution. So, it's not a problem of light cache or VRay.

Please, try this on each machine, just to be sure all of them are using the same Forest files:

1) Stop Max and VRay Spawner.
2) Delete plugins\ForestPackPro.dlo and ForestVRay20.dll from the Max folder.
3) Reinstall Forest.

If that doesn't solve the problem, send us a stripped scene to First i want see what of the images should be the correct. From here, we'll continue with other tests.
Title: Re: Forest Pack DR issues
Post by: MJ4821 on October 09, 2013, 02:48:38 PM
We have tried your suggested solution and are still experiencing the same error unfortunately. In case it might help when working out the reason and a solution, when rendering the scene from further away you tend not to get this problem. That said, if you look toward the top and bottom left of the attached image you can see some artfacts/anomalies where this is occurring, effectively as non-rendered objects.

With regard to sending you a file what is the maximum size you can accept and by what means?
Title: Re: Forest Pack DR issues
Post by: iToo on October 09, 2013, 04:20:12 PM
I suggest you use a web sharing service as WeTransfer, it accepts large files. Please, include also instructions to get the image of your first post (camera name, frame number, etc.), so we compare the result.
Title: Re: Forest Pack DR issues
Post by: MJ4821 on October 09, 2013, 05:21:21 PM
OK, thanks for the advice; we'll package something up as soon as we can and send it over to you.
Title: Re: Forest Pack DR issues
Post by: iToo on October 10, 2013, 02:53:15 PM
After several tests here, i can confirm the problem is caused by camera clipping. For some reason, the camera FOV returned by DR nodes is different from normal render. We must investigate this issue on deep.

As workaround, instead turning off clipping completely, you may increase "Camera->Expand" and "Camera->Back offset" values.