Itoo Software Forum

Author Topic: Forest Pack parts disappearing  (Read 1731 times)

trono

  • Newbie
  • *
  • Posts: 1
Forest Pack parts disappearing
« on: July 07, 2017, 09:49:44 PM »
While I'm waiting for support to reply; We have an issue after updating to V-Ray 3.6 and ForestPack 5.4.0 where, at the start of our rendered sequences, we see parts of the forest pack objects disappear, and flicker on/off. This only happens at the beginning of the render jobs, and the same render nodes that might render incorrectly at the first frame seems to render fine at later frames, in the same render job. I cannot find any pattern in which servers are doing this. If I resubmit the job, different frames might render incorrectly. But every time I do see after 40ish frames are rendered, every frame will render correctly. Which match up to our 40 nodes render farm. Seems random nodes get issues rendering the first frame they get assigneed, but the second and onward are fine. We have multiple scenes at different frame ranges coming from this file, and every sequence sees the same issue after the update.

I tried limiting to only render at 5 nodes simultaneously to see if it could be a network issue (latency downloading maps etc.), but no go. All servers are running Max2016 SP4 Ext2. We didn't see this issue before we updated, but also I have problems recreating it on new and simpler scenes. Problem is that this is a production scene that needs to go to rendering asap.

In the video below I've cleared out everything besides the ground, forest pack objects and lighting.
Any suggestions are appreciated.


https://vimeo.com/224650349
password: fp

narsov

  • Newbie
  • *
  • Posts: 5
    • narsov.com
Re: Forest Pack parts disappearing
« Reply #1 on: July 08, 2017, 10:58:30 AM »
Hi,

I had same disappearing issue, it was the spline created for Forest area. I created new spline area and add to Forest and now is working fine.

Best,
Nikola

Nestamonk

  • Newbie
  • *
  • Posts: 14
Re: Forest Pack parts disappearing
« Reply #2 on: July 14, 2017, 01:38:43 PM »
Has anyone from ITOO  responded to this? We removed the vray 2-sided material from the leaves of the trees and it rendered properly. 

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3094
    • iToo Software
Re: Forest Pack parts disappearing
« Reply #3 on: July 14, 2017, 02:30:51 PM »
Hi, this case was attended by e-mail, and it seems a problem on the V-Ray side, because a downgrade from V-Ray 3.6 to 3.5 fixed it.
The customer opened a support ticket with ChaosGroup.

Checking the video, we noticed some trees were rendered partially (branches, but not leaves). That points to some problem with rendering, materials or something else, which only ChaosGroup can identify.
Also, applying a material override with a basic material renders correctly, which is significative.

I hope this information helps in your case. If not, please open a new post or write us with details about the problem, configuration, and all information you can provide.

Thanks,
« Last Edit: July 14, 2017, 02:32:53 PM by iToo »
Carlos Quintero
iToo Software

narsov

  • Newbie
  • *
  • Posts: 5
    • narsov.com
Re: Forest Pack parts disappearing
« Reply #4 on: July 14, 2017, 02:58:50 PM »
Hi,

I did upgrade to 3.6 vray and latest Forest pack on 3dsmax 2018 and I thought it was the spline. Sometimes Railclone does that when I upgrade. But, I got again that same rendering problem  ??? . In my case I noticed that if physical camera is used with enabled motion blur on frame 0, render nodes are not rendering the leaves. I turned off the motion blur on the camera and everything was fine, also using motion blur on 2,3rd frame works fine.

Best,
Nikola

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3094
    • iToo Software
Re: Forest Pack parts disappearing
« Reply #5 on: July 15, 2017, 09:17:59 AM »
Hi Nikola,

It seems a V-Ray 3.6 issue as well. Please report the problem directly to ChaosGroup.

They will contact with us, if see the problem may be related with our plugins.

Thanks,
Carlos Quintero
iToo Software

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3094
    • iToo Software
Re: Forest Pack parts disappearing
« Reply #6 on: July 16, 2017, 09:03:19 AM »
According to their release notes, this problem should be solved in V-Ray 3.60.02:

https://forums.chaosgroup.com/forum/v-ray-for-3ds-max-forums/v-ray-for-3ds-max-announcements/960238-v-ray-3-60-02-for-3ds-max-is-available

(*) V-Ray: Disappearing geometry with VRayBlendMtl, Motion Blur and Forest Pack;
Carlos Quintero
iToo Software

ML2660

  • Newbie
  • *
  • Posts: 32
Re: Forest Pack parts disappearing
« Reply #7 on: August 11, 2017, 02:27:17 PM »
Can anyone confirm this is solved with ipr?
Have the latest vray installed, but not the latest forest.(have to renew my subscription after the holidays)
If not, did anyone try the latest nightly build to see if these issues have been resolved?

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1396
Re: Forest Pack parts disappearing
« Reply #8 on: August 11, 2017, 03:20:34 PM »
Hi,

Upon our quick internal tests, it's working fine in the V-Ray 3.60.03. It should be fixed since Build 3.60.02 - (*) V-Ray: Disappearing geometry with VRayBlendMtl, Motion Blur and Forest Pack;.

Best regards,

Shapethelight

  • Newbie
  • *
  • Posts: 3
Re: Forest Pack parts disappearing
« Reply #9 on: September 13, 2017, 10:28:25 PM »
I'm working on a big project and i'm using 3ds Max 2017, Vray 3.60.03 and Forest 5.4.
I got the issue described in this post.
I've tryed all the things i could suppose to fix the bug, but in the best case i loose random forest object's parts changing view from Perspective to VrayCam.
I'm really in trouble since i need to close this project in 2 weeks. Can you help me fixing the bug?

I can send the project file if needed.. but the priority is to enable my team to work on it asap.
Thx for the help.

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1396
Re: Forest Pack parts disappearing
« Reply #10 on: September 14, 2017, 10:12:54 AM »
Hi,

Sorry to hear you're facing these troubles. If possible, feel free to send us the problematic scene. Ideally, please try to reproduce the problem with a minimal scene and send us such scene to analyse it here. Thanks in advance for any feedback on this issue you can share about it with us / our user community.

Best regards,

Shapethelight

  • Newbie
  • *
  • Posts: 3
Re: Forest Pack parts disappearing
« Reply #11 on: September 14, 2017, 09:10:43 PM »
Thx for the support. With my project file it's really easy to reproduce the bug: just change from perspective to camera and all the forest objects get cutted out.
At the moment i got a workaround cloning all my forest objects in a new layer, i got them frozed and not visible. Every time i bug the old forest objects i delete them and clone again from the backup clone. You can understand that's not a workable way :)


Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1517
Re: Forest Pack parts disappearing
« Reply #12 on: September 15, 2017, 11:47:35 AM »
Hi, This sounds like a separate problem from the original post because the plants are vanishing when you trigger a camera view. Could it be the camera limit to view feature is enabled? This will cull plants based on the camera view and could cause behaviour similar to that which you describe.



I hope that helps, please let me know if you have any further questions.

Many Thanks,

Paul
Paul Roberts
iToo Software

Shapethelight

  • Newbie
  • *
  • Posts: 3
Re: Forest Pack parts disappearing
« Reply #13 on: September 16, 2017, 03:58:29 PM »
Unfortunately that's not the problem. The bugged Forest object in my scene don't get rendered too... If it was a visibility issue, i should see it in the rendered scene...

Nestamonk

  • Newbie
  • *
  • Posts: 14
Re: Forest Pack parts disappearing
« Reply #14 on: September 18, 2017, 05:44:48 PM »
If you are using proxies from a previous version of Vray try importing as mesh and reproxy the object. We also noticed its best to not proxy objects when using forest pack.