Itoo Software Forum

Author Topic: Forest plants changing at random from frame to frame  (Read 384 times)

PQ2910

  • Newbie
  • *
  • Posts: 5
Forest plants changing at random from frame to frame
« on: January 12, 2018, 02:51:33 PM »
Hi Itoo

Please can you help I am having an issue where my plants look different from one frame to the next at random intervals I have attached example images.
Have you seen this before and how do I stop this from happening?

I am using forest pack 5.4.1 3dsmax 2018.4 rendering with vray 3.62.02 on Windows 10

Thank Anthony

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1472
Re: Forest plants changing at random from frame to frame
« Reply #1 on: January 12, 2018, 03:37:06 PM »
Hi,

First let me mention, as you're using the V-Ray renderer 3.60.02, that in V-Ray 3.60.01 & 3.60.02 there were few issues reported (in some cases, switching off Embree fixed it) and installing the 3.60.03 would be highly recommendable.

Might be, you're using the Camera - Distance Falloff - Density feature? When rendering a "walk-through" animations, this feature shouldn't be used to prevent any kind of troubles. As mentioned in our on-line reference guide: "Be careful if you use falloffs with camera motion, because items may appear or disappear suddenly (the distance to camera changes when moving)."

It that's not the case, I would suggest you do a quick test with this problematic Forest object in the Custom Edit mode to see if there is any difference.

Please feel free to send us your scene to check it here. Thanks in advance.

Best regards,

PQ2910

  • Newbie
  • *
  • Posts: 5
Re: Forest plants changing at random from frame to frame
« Reply #2 on: January 16, 2018, 12:09:04 PM »
Hi Michal

I have updated to the latest Vray (not beta) and I am still having the same issue and it's not the camera Distance falloff.
it's repeatable so I have put a scene together please expect an email shortly and I would appreciate any help as I really need to finish this animation.

Thanks

Anthony

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3148
    • iToo Software
Re: Forest plants changing at random from frame to frame
« Reply #3 on: January 17, 2018, 10:54:29 AM »
Hi Anthony,

The problem is in the SOIL PAT GAR AREA spline, used for the FT FWR & SHRUB object.
Some sub-splines are duplicated and stacked in the same position. This is causing precision errors in FP, generating different distributions randomly.

Please, check all your splines and remove duplicates. That should fix the problem.

One trick to "lock" Forest distributions, and be sure there are not unexpected changes while rendering, is to switch FP objects to Custom Edit mode.
That may be specially useful if you are preparing the scene for the render farm. Of course, this is valid only for static distributions.

One more thing: if you don't use camera clipping or other camera effects, you can increase performance a bit, turning off Camera->"Auto assign to active view", and clicking the "Clear" button, to remove the camera assignment.
In this way, Forest is not rebuilt witch each camera change (which is not necessary in this case).

I hope that helps.
Carlos Quintero
iToo Software

PQ2910

  • Newbie
  • *
  • Posts: 5
Re: Forest plants changing at random from frame to frame
« Reply #4 on: January 17, 2018, 01:15:48 PM »
Thank you Carlos for taking the time to look through my model and explain the cause of my issues I really appreciate it.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3148
    • iToo Software
Re: Forest plants changing at random from frame to frame
« Reply #5 on: January 17, 2018, 03:48:16 PM »
No problem. I'm glad i could help out.
Carlos Quintero
iToo Software