Itoo Software Forum

Forest Pack => Forest Pro (*) => Topic started by: CCGI on April 14, 2021, 03:02:05 PM

Title: FP is getting FAR Too Slow
Post by: CCGI on April 14, 2021, 03:02:05 PM
So I've emailed through to iToo Support regarding the following:

"Hi there,

It seems every release FP gets slower and slower to open.

During the SOA academy I asked you guys about your roadmap to get FP and RC to speed up/utilize multithreading.
I've attached a 2:21 video to show you just what I mean and you can imagine how infuriating it is that it just gets slower and slower..
Been using your plugins for the past 7/8 years and you need to make it more usable.
Can you investigate this as a matter of priority. It would make myself and the team here much happier to have a responsive piece of software to use.
Happy to chat through what we can do to address this here also if you have any ideas of where to start.
The video is just a blank scene, I'm waiting for one of the logical processors in our 64 logical processor bank to complete whatever it is that it's needing to process ahead of utilizing FP. Surely if spread over the full available processors we could have a much nicer UX."


Had the following Response:

"Thanks for contacting iToo Software and for your confidence in our plug-ins.
I'm sorry to hear you're facing these troubles. Please try setting these options in the forestpack.ini located by default under C:\Users\karma\AppData\Local\Autodesk\3dsMax\2020 - 64bit\ENU\en-US\plugcfg:

checkTexturePaths=0
collectTexturePaths=0

to see if there's any difference.
Thanks in advance for any further comments on this issue you can share about it with us / our user community (in case some user(s) will run into similar troubles)."


After trying this fix we're still getting loading times of >2minutes

Why is this  the case? It seems to be getting slower and slower each release in terms of initial start-ups..

This also has a vast impact on loading times when opening scenes with FP already in. - Happy to pack up these scenes for you but I've a feeling it's the same issue so would like my initial problem solved.

I can confirm this is also the case for other users with similarly spec'd workstations in our team.



I've since been tasked with producing a minidump of 3ds max so will be sending this on shortly, fingers crossed for a speedy fix.

Message was as follows:
"Thanks for your swift reply. Please, download the Process Explorer https://docs.microsoft.com/en-gb/sysinternals/downloads/process-explorer and during the "freeze", run it, find the "3dsmax.exe" process, select it, go to Process > Create Dump > Create Minidump..., save the file, compress it and send it to us by using the Wetransfer. Hopefully, it'll point to the problem source. Thanks in advance."
Title: Re: FP is getting FAR Too Slow
Post by: iToo on April 14, 2021, 04:28:03 PM
Hi,

First of all, that loading time of 2 minutes is not normal. That indicated some kind of problem, because even in the worst case, FP should not take more than a couple of seconds to initialize.
There is nothing we can optimize or improve using multithreading. You see one CPU at 100% just because Max is freezed at some specific process.

In this case, checking your minidump, we see Max is stucked trying to load the Forest templates.
These are a set or simple geometries used for billboards. Usually are stored at C:\Program Files\Itoo Software\Forest Pack Pro\geometry\objects\geometry1.max.
Under normal conditions, this step should be immediate. Something is interfering with the load process.

Since this issue also happens with other users of your team, there must be something in common, which is causing it.

- In your organization, Forest is installed by default, or do you use some custom configuration ? (i.e. Forest files moved to a network folder)
- What other plugins or scripts do you use ? We have seen cases of custom scripts causing undesired side effects.

I would suggest you try reinstalling Forest with the default settings, and also remove temporary other plugins or scripts, to see if there is some difference.

Title: Re: FP is getting FAR Too Slow
Post by: CCGI on April 14, 2021, 04:59:31 PM
Hi iToo,

Thanks for the reply; when installing we do the following:

TICK -  Advanced installation
Set a Shared Folder on the NAS "A:\iToo Libraries"

Scripts/Plugins commonly installed include:
GeOAutoSave.ms
ColorCorrect.dlm
BerconMaps_2020_64.dlt
Anima2.MAX.dli
FloorGenerator_max2020_64bit.dlm
glue.dlu
CityTraffic.dlo
MadCar.dlo
MultiTexture_max2020_ver2.04_64bit.dlt
splineOffset.dlm
tyFlow_2020.dlo

others: Pixamoon BitmapTracking/Resizing v1.71
Pulze - Scene Manager
Title: Re: FP is getting FAR Too Slow
Post by: CCGI on April 14, 2021, 05:01:47 PM
Just had a go launching it in a fresh install of MAX 2021 and it's night and day.

Took approximately 2-3 seconds..

Any idea of the scripts/plugins we use can cause the delay?
Title: Re: FP is getting FAR Too Slow
Post by: Rokas on April 14, 2021, 05:44:16 PM
We don't. But we are interested to know what will You find. Try installing Your usual plugins in batches of ~3 and test the performance after each batch.
This should be fairly quick way to troubleshoot which extension causes the troubles.