Itoo Software Forum

Author Topic: Geometry template 'One Plane' not found Error  (Read 744 times)

IJ2087

  • Jr. Member
  • **
  • Posts: 74
Geometry template 'One Plane' not found Error
« on: March 22, 2016, 11:46:57 PM »
I have a file that has a forest pro that generates a error: Geometry template 'One Plane' not found Error.
If I click a forest object it will generate an error in Korean letters. The template drop down menu has blank and Korean entries where the Plane templates would be.

Is there a way to reset these templates? I am not using the template planes in the forest scatter.

Is this a bug or some odd file we ended up using that has affected our files?

Max 2016 SP3 Forest Pro 4.4.1
« Last Edit: March 22, 2016, 11:57:31 PM by IJ2087 »

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1555
Re: Geometry template 'One Plane' not found Error
« Reply #1 on: March 23, 2016, 09:35:32 AM »
Hi,

Would you please send us that scene through WeTransfer to support@itoosoft.com to analyse it here? Thanks in advance.

Did you try to open it on other computer (does it behave in the same way)? It might be related to some other plug-in / script conflict.

Best regards,

IJ2087

  • Jr. Member
  • **
  • Posts: 74
Re: Geometry template 'One Plane' not found Error
« Reply #2 on: March 23, 2016, 03:45:00 PM »
Ok I just sent it. The file behaves differently if you open it again.
This file gave me a error but it seemed to fix itself by switching the templates to the defaults.

The file is stripped of everything else as well since the file was pretty large. I can send another when I get a chance.

Other people in my office have had this happen randomly.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3359
    • iToo Software
Re: Geometry template 'One Plane' not found Error
« Reply #3 on: March 24, 2016, 09:04:11 AM »
Hi, checking your scene, one of the parameters related with billboards was corrupted. As you pointed out, Forest includes a self checking and fixes it when object is edited.

Only time we have seen a similar problem was caused by a custom script, which was deleting the "forest_templates" layer, used by Forest. You can read the case here.

Do you use some script or plugin which would cause a similar behaviour ?
Carlos Quintero
iToo Software

IJ2087

  • Jr. Member
  • **
  • Posts: 74
Re: Geometry template 'One Plane' not found Error
« Reply #4 on: March 24, 2016, 04:00:45 PM »
Thanks. We use a number of plugins and scripts but this appears to happen at random so it would hard to say which plugin/script I would suspect. Is there a way to diagnose this?
The only plugin that would interact with Forest is Vray Material and Vray Proxies.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3359
    • iToo Software
Re: Geometry template 'One Plane' not found Error
« Reply #5 on: March 24, 2016, 04:42:22 PM »
The corrupted data (in this specific case) was stored in this parameter: "tempnamelist".
If everything is correct you should get the following data from Maxscript:

Code: [Select]
$.tempnamelist

#("One Plane", "One Plane", "One Plane", "One Plane", "One Plane")

With one entry for each item of the Geometry List. In your scene instead, there were non-ascii characters (as shown in your screenshots).

A way to diagnose it would be to check this parameter periodically, for example when scene is saved or rendered.

Carlos Quintero
iToo Software

IJ2087

  • Jr. Member
  • **
  • Posts: 74
Re: Geometry template 'One Plane' not found Error
« Reply #6 on: March 24, 2016, 06:30:06 PM »
Here is the latest. Open the file twice and it happened both times clicking the forest. It seems to happen everytime I click any forest now:

Here is what copies to the clipboard:
File: ..\Forest\forspec.cpp
Line: 189

Code: [Select]
Geometry template 'One Plane' not found !
Replacing it by ''
Geometry template 'One Plane' not found !
Replacing it by '岸Ú'

Code: [Select]
$.tempnamelist
#("", "", "", "", "", "", "", "", "", "", "", "", "", "", "", "", "", "")
« Last Edit: March 24, 2016, 06:36:58 PM by IJ2087 »

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3359
    • iToo Software
Re: Geometry template 'One Plane' not found Error
« Reply #7 on: March 25, 2016, 09:29:08 AM »
Unfortunately we cannot reproduce the problem here. Does it happen editing the clean scene you sent us, or only with your production scene ?
Carlos Quintero
iToo Software