Itoo Software Forum

Author Topic: Grouped objects unable to use as Forest Lib asset :-(  (Read 201 times)

Adam86

  • Newbie
  • *
  • Posts: 30
Grouped objects unable to use as Forest Lib asset :-(
« on: April 13, 2018, 11:19:31 AM »
Hi All, I am really trying to work out the best way to reference a house which is made up of several 3D objects, some have Vray displacement modifiers to the bricks for instance, also there are rail-clone emitters for generating the roof tiles, guttering etc... This house is then grouped and saved in it's own 3ds max file.

What I want to do is reference that house and instance it several times in different locations in another file - I want the ability to keep it connected to this one house type file so that if I update this one house , it'll have a knock on effect to all referenced instances.

I thought I could potentially do this with Forest Pro, create it as a lib asset then reference the file, but as soon as I generate the forest emitter I get the error "error merging group from library" - I have tried both 'merge into scene' & "Xref to Library" I get the same error for both and it fails to come in.
« Last Edit: April 13, 2018, 11:21:05 AM by Adam86 »

Adam86

  • Newbie
  • *
  • Posts: 30
Re: Grouped objects unable to use as Forest Lib asset :-(
« Reply #1 on: April 13, 2018, 02:00:26 PM »
Still experimenting with ways in order to achieve this, I have found one that looks promising up to a point - I found a script called Project Manager which makes applying a dummy to an xref Scene very quick, however it falls down if I mirror the xref as anything Railclone related comes mental and flips about! Is there anyway to keep this as a fix? I know I'm asking for a railclone fix in the forest section....

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 512
Re: Grouped objects unable to use as Forest Lib asset :-(
« Reply #2 on: April 13, 2018, 03:54:26 PM »
Interesting question. Thank You, Adam.

I got OK results using regular object xref-ing (although- no displacement in ForestPack ).




Please share Your problem(-s) in more detail, and with maxfile if possible.
« Last Edit: April 13, 2018, 04:12:54 PM by Rokas »

Adam86

  • Newbie
  • *
  • Posts: 30
Re: Grouped objects unable to use as Forest Lib asset :-(
« Reply #3 on: April 18, 2018, 04:49:13 PM »
Rokas, can you explain to me your method please - I have avoided Xref Objects because it is too buggy, I need a process in which I can update the files when required and Xref Objects doesn't allow me fully to do that. I am trying Xref Scene currently however I am now getting different types of problems.

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 512
Re: Grouped objects unable to use as Forest Lib asset :-(
« Reply #4 on: April 19, 2018, 09:21:42 AM »
Sure.
Create house in max file. Set all objects pivots to same location (For ForestPack Group to work). Group object.
Save max file as usual.

Create new empty Max scene.
Open XRef Objects dialog


Add xref file:


Use that if group in forest pack.
Once updated Your first house max file use update button:


ForestPack does not update itself automatically. So update Forest Geometry by selecting same group again.