Itoo Software Forum

Author Topic: Help with network license  (Read 4018 times)

JU2073

  • Newbie
  • *
  • Posts: 7
Help with network license
« on: February 21, 2013, 05:52:41 PM »
Hello,

The last week I bought Forest Pack Pro 3.9.6. with a network license. I installed it without any problems in just one computer and start work, but today I reopen the 3dmax file and when I tried to render it, shows me the following message:

"Forest Pack cannot find a license server in the network. Please contact with you network administrator"
"Without a valid license, the Forest objects cannot be edited or rendered"

Inmediately, I went to the License Manager, and it looks working ok, the license is active, and the server is running. What might be happening?

Additional, maybe you can help me to install the network license in another computer, because I have tried to do it, and  send me a message saying that there is another server running, so I it means that i'm doing something wrong, but I can't find where I'm failing.

Thanks a lot.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Help with network license
« Reply #1 on: February 21, 2013, 06:03:17 PM »

Our Network licensing system is designed to have an unique License Server running (usually installed in a separate machine). Multiple servers, would create this type of problems.

Please, uninstall the extra license servers (if any), restart the service (License Manager->License Server->Stop / Start) and try again.

For the workstations, only it is necessary to install Forest using the setup program, and selecting the Network/Floating License mode.

Carlos Quintero
iToo Software

JU2073

  • Newbie
  • *
  • Posts: 7
Re: Help with network license
« Reply #2 on: February 21, 2013, 06:19:34 PM »
Hello, and thanks for answering

I uninstalled the server in the other computer and reinstall Forest in mine. I opened the license manager and ask me again for the code, I put it again and it shows that is working:

License: Type Network and it looks active
Computers: none
License server: server is running

Thanks again for helping.

JU2073

  • Newbie
  • *
  • Posts: 7
Re: Help with network license
« Reply #3 on: February 21, 2013, 06:33:13 PM »
Also, the first time I tried to install the license manager on my server (WD Sentinel DX4000) but it does'nt work, so I installed it in my computer. It might be related with my problem??

Thanks

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Help with network license
« Reply #4 on: February 21, 2013, 08:05:18 PM »

Perhaps the software was installed in the server, and the service continues running. What error did you get exactly ?

In any case, it is recommendable to check if the server software is installed on it yet, and remove it.

Carlos Quintero
iToo Software

JU2073

  • Newbie
  • *
  • Posts: 7
Re: Help with network license
« Reply #5 on: February 21, 2013, 08:34:57 PM »
I was looking at the server but it´s already uninstalled.

I get this error:

"Forest Pack cannot find a license server in the network. Please contact with you network administrator"
"Without a valid license, the Forest objects cannot be edited or rendered"

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Help with network license
« Reply #6 on: February 21, 2013, 09:02:12 PM »

Ok, i though it was an error when installing the server software.

Probably there was a communication issue between the workstation and the server, usually the firewall. If that helps, our software uses TCP/UDP Port 16720.

Carlos Quintero
iToo Software

JU2073

  • Newbie
  • *
  • Posts: 7
Re: Help with network license
« Reply #7 on: February 21, 2013, 10:06:02 PM »
Hello, I uninstalled every forest and every license in all the computers. I installed the license in a new location that allows to all the network computers to log in. Now I installed the Forest in my computer and put in the host and the port you indicate to me (TCP/UDP Port 16720). When I run forest the error change:

"A error ocurred while was attemping to connect with the License Server TCP/UDP: Winsocks error 11004, El nombre solicitado es válido pero no se encontraron datos del tipo solicitado."

I think we are near to make it work, but in the license manager I have never achieved to make appear a license (just the network license but not the one with the key symbol) neither any computer (hostname, IP, etc).

I wondered if maybe the trouble is with the license code or something. I really need your help, I have to present some renderings at monday, and forest is my unique one chance to achive it now.

Thanks a lot.

yuv

  • iToo Software
  • Sr. Member
  • *****
  • Posts: 312
  • iToo Software - CEO
    • Itoo Software
Re: Help with network license
« Reply #8 on: February 21, 2013, 10:56:19 PM »
"TCP/UDP" port 16720 is the type of protocol that you need to open in the firewall or antivirus, not a server name.  In that field you should enter the IP of your server, or in most of cases, just leave the automatic search mode as shown in the image.

You should contact with yout IT administrator to verify your network security options. The problem is allow this protocol to pass between computers.
Daniel Quintero
Itoo Software
www.itoosoft.com
daniel@itoosoft.com

JU2073

  • Newbie
  • *
  • Posts: 7
Re: Help with network license
« Reply #9 on: February 21, 2013, 11:22:45 PM »
I tried both, when I entered the IP it says that I cant acces to the route, but I have still all the permissions, and when I leave the automatic search mode appears the first error.

There is no way to change to a stand alone license??? I really need to make it work soon :(

yuv

  • iToo Software
  • Sr. Member
  • *****
  • Posts: 312
  • iToo Software - CEO
    • Itoo Software
Re: Help with network license
« Reply #10 on: February 21, 2013, 11:48:45 PM »
We switched your license to stand-alone type, please see your email inbox for new codes and instructions.
Daniel Quintero
Itoo Software
www.itoosoft.com
daniel@itoosoft.com

JU2073

  • Newbie
  • *
  • Posts: 7
Re: Help with network license
« Reply #11 on: February 22, 2013, 12:02:29 AM »
I really really thank you, I actually reinstalled the forest with the stand-alone license and it finally works perfect.

Thanks for helping me all the day and solve the problems.

I hope to dont need to bother you anymore.

Thaks again  :)

OH9242

  • Newbie
  • *
  • Posts: 9
Re: Help with network license
« Reply #12 on: August 07, 2014, 08:51:58 AM »
Hello, I have the same problem.

Two computers with 3dmax, one of them being a server (I have a network licence). In the past it worked ok if I remember well (I mean I worked on the server and render things with bouth toghether).
Now I reinstalled windows on the nonserver computer with only the forest 4.03 exe and I`ve set the network/floating licence option there.

But when I try to put an forest object in the nonserver computer I get that "Forest Pack cannot find a license server in the network. Please contact with you network administrator" (is this a limitation of my licence or a communication problem)

On the server computer I have set in the firewall so the itoo server is free to communicate. I tried also on the server computer to have the 3dmax open or closed. Nothing helps. In the license detalils is say licenced for 1 user. and status activated.. Maybe is because the subscriprion period is expired? On bouth computers I have the same version 4.03.

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1547
Re: Help with network license
« Reply #13 on: August 07, 2014, 09:29:43 AM »
Hi,

Please try to set the network license to the IP of the server rather than finding it automatically. This can be done using the "Change License Mode" wizard after setting Network license mode in Configure the Network License window. Attaching screenshot.

If the issue still persist, please check this post how to test if it's a communication issue.

"Please, try using a TCP scanning tool (as nmap) to test the server port from a workstation. In this way:

nmap -p 16720 <your-server-address>

It should return the following result:

PORT STATE SERVICE
16720/tcp open unknown


Also enable the debug mode in the server, try to use the plug-in and send us the licserver.log."

Kind regards,

OH9242

  • Newbie
  • *
  • Posts: 9
Re: Help with network license
« Reply #14 on: August 07, 2014, 02:31:25 PM »
Starting Nmap 6.46 ( http://nmap.org ) at 2014-08-07 15:20 GTB Daylight Time

Nmap scan report for 192.168.1.5

Host is up (0.00s latency).

PORT      STATE    SERVICE

16720/tcp filtered unknown

MAC Address: BC:5F:F4:4A:C9:E9 (ASRock Incorporation)



Nmap done: 1 IP address (1 host up) scanned in 11.44 seconds

I think is "filtered" in stead of "open"?

I have an avg free antivirus wich doesn`t have ythe firewall available. In windows firewall at the exceptions I have Itoo server listed.