Itoo Software Forum

Author Topic: Library Browser_Maxtree  (Read 194 times)

Lucas<>

  • Newbie
  • *
  • Posts: 7
Library Browser_Maxtree
« on: March 28, 2022, 01:43:30 PM »
Hi everyone,

I have a problem with the Maxtrees libraries. I've noticed that all of the new packs contain the ready "index" files which should work for the forest libray. Some of them are loading indeed, but the others don't want to load at all ( don't show the thumbnails). The one which are loaded shows me the thumbnail and it seems that they are working, but when I try to use them it pops up the message "Load failed. There is not any Forest object selected". So basically I cannot use them at all.
I attach few screenshoots and index files. Both the one which is loading (MT_PM_V12) and the one which is not (MT_PM_V14).

PS. All the packs are on the office server and I cannot run the max as an administrator, since I'm not in charge of that.

Please let me know if you need any further details.
« Last Edit: March 28, 2022, 01:59:31 PM by Lucas<> »

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2457
Re: Library Browser_Maxtree
« Reply #1 on: March 28, 2022, 01:49:48 PM »
HI,

It looks as though the folders need to be in another subdirectory, so it should be something like

- Maxtree Folder (this is the path  you add to the Forest Library
--Maxtree Collection Folder
---index.xml
---matlibs
---thumbnails
---etc.

"Load failed. There is not any Forest object selected" happens when you have opened the library browser but you don't have a Forest Object selected in the scene that you want to add the objects to,

I hope that helps.

Paul
Paul Roberts
iToo Software

Lucas<>

  • Newbie
  • *
  • Posts: 7
Re: Library Browser_Maxtree
« Reply #2 on: March 28, 2022, 01:56:20 PM »
Hi Paul,

Thanks for the quick reply.
I'm pretty sure that the hierarchy is correct
Please see attached the index.xml and prntsrc

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2457
Re: Library Browser_Maxtree
« Reply #3 on: March 28, 2022, 02:02:19 PM »
It looks correct, but you need to add the Plant Models v.14 (or even the MaxTree) folder to the library instead of using the MT_PM_V14... folder. You can add it from the library's Preferences



I hope that helps,

Paul
Paul Roberts
iToo Software

Lucas<>

  • Newbie
  • *
  • Posts: 7
Re: Library Browser_Maxtree
« Reply #4 on: March 28, 2022, 03:12:33 PM »
Well, that's what I did. It shows me the thumbnails but I cannot use this model, when I try it pops up the same message "Load failed. There is not any Forest object selected"

See attached image

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2457
Re: Library Browser_Maxtree
« Reply #5 on: March 28, 2022, 03:17:11 PM »
Apologies if this is a silly question, but do you have a Forest Pack object selected in the scene? It needs this to know which object to load the models into.

Cheers,
Paul
Paul Roberts
iToo Software

Lucas<>

  • Newbie
  • *
  • Posts: 7
Re: Library Browser_Maxtree
« Reply #6 on: March 28, 2022, 03:18:28 PM »
heh, no worries. Seems to be all good in Item Settings as well.

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2457
Re: Library Browser_Maxtree
« Reply #7 on: March 28, 2022, 03:24:23 PM »
Sorry I mean that you should follow this procedure to load objects from the library:

1 - Go to the create panel, go to the iToo Software group and add a new Forest Pack object to the scene.
2 - With the Forest object still selected, open the library browser. Select an object from the library and click Load Selected
3 - The objects will be added to the geometry list.

I hope that makes sense.

Paul
Paul Roberts
iToo Software

Lucas<>

  • Newbie
  • *
  • Posts: 7
Re: Library Browser_Maxtree
« Reply #8 on: March 28, 2022, 03:29:23 PM »
Alright my apologies... All good. Reason why I was asking that is becouse I wanted to drag and drop this tree on the empty max canvas. I've just realised that I can only use it when I first create forest ...  :-X.
It's all working fine. Thank you for your time Paul.

Best

PS. now I'm thinking it would be nice to drag and drop it without forest as well :). Use it as a assets library not only attached to forest

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2457
Re: Library Browser_Maxtree
« Reply #9 on: March 28, 2022, 03:32:15 PM »
Glad it's all working. You're not the first to ask about drag and drop, it's something we'd be interested in developing too. No promises, but it's on our wishlist!

Bests

Paul
Paul Roberts
iToo Software