Forest Pack > Forest Pro (*)

Library paths question

(1/3) > >>

Quite some time ago I slightly modified my User Library folder structure. Ever since I get an "paths not found" message when I open scenes in new projects that I have added some forest pack items to. It is always for the same two paths.

The 3Ds max "path not found" message appears when I first open the scene in Max. I check commit paths anyway and the scene opens and no problem from there on. It is just kind of annoying/tedious and I would like to fix it so that doesn't keep happening.

I'm just no sure where or how to delete the old paths that forest Pack adds and then 3ds max keeps looking for. The folders no longer exists on my drive so...why is forest Pack still loading them as path locations when I create a forest object and how can I fix that?

Paths not found:


d\data\max\mymesh02\plants-landscape-sitework\myforest-libraries\vp real boulders\maps

There is also this other path not found shown below. I do not believe I did any modification of this library or it's paths. I notice (as downloaded and installed on my system) that the Maps folder is a sub folder of the Model folder versus being a subfolder of the Presets folder. 3DS Max is looking for it and returning the path not found message per the below path.

d\data\max\mymesh02\plants-landscape-sitework\myforest-libraries\The3DGarden\Field Plants and Grasses 01\Presets\maps

I hope this is all understandable and thanks in advance for any help.

Michal Karmazín:

All paths for used assets can be configured (removed when needed) within the 3ds Max configuration under Customize - Configure User Paths - External files – these are stored in the 3dsmax.ini within the [BitmapDirs] section.

Let me add, that generally, we recommend resolving all references used by Forest to absolute UNC paths. It's not necessary, but usually, this way you avoid any texture path issues while using distributed rendering. The "default" file handling is controlled by 3ds Max and could be adjusted under Options - Preference Settings - File Handling - Convert file paths to UNC. This way all your scenes should use UNC paths.

I hope that helps.

Best regards,

Thanks for your reply Michal. I think it is Customize>Configure Project Paths-External files you are referencing? I understand I can delete the paths from there.

My question is why does Forest Pack add these no longer existing paths to the Project Paths whenever I first create a Forest Object in a new scene? What/where/how do I need to do to get rid of the reference to those no longer existing paths so they do not always get added by Forest Pack and then every time I open the scene I get the "paths not found" message?

Update. I re-read your reply and Opened the 3dsmax.ini file and deleted the two paths:


d\data\max\mymesh02\plants-landscape-sitework\myforest-libraries\vp real boulders\maps

That seemed to do the trick so thanks for that!

I did not see the path belwo in the .ini file:

d\data\max\mymesh02\plants-landscape-sitework\myforest-libraries\The3DGarden\Field Plants and Grasses 01\Presets\maps

But, when i opened the scene this time I did not get any "path not valid" messages so...all good for now. Thanks for your help!

I spoke too soon. This problem remains. FP keeps adding several paths that I deleted form my FP Libraary. I deleted the paths from Max Configure Project Path, deleted from 3dsmax.ini, and deleted fromm the project .mxp file.

Still on new project or on adding some FP these now non-existing paths get added back into the three locations listed above.

i suspect it may be because when I deleted the paths form my FP Library I did that from within Windows Explorer vs the FP Library Browser.

Where can I delete these no longer existing paths so they do not keep getting added back into my projects?

Thanks in advance for any help!


[0] Message Index

[#] Next page

Go to full version