Itoo Software Forum

Author Topic: Loading Presets causes MAXScript error and Geometry don't connect to Forest  (Read 205 times)

Shawn Olson

  • Jr. Member
  • **
  • Posts: 89
  • Wall Worm
    • Wall Worm
Whenever I try to load the Stone Presets from FP, I get a MAXScript error:

Quote
Warning : Can't find object "" in the source scene

After this warning, Forest gets populated with a bunch of Geometry entries but none of the imported geometry gets tied to those entries... and the materials are not loaded onto the geometry.

I tried going into the presets to check for bad scripts or if one of the XML/json files pointed to an object that doesn't exist, but I could not find anything that stuck out. This issue
Shawn Olson
Product Management Team @ Autodesk for 3ds Max
Developer of Wall Worm Tools

Shawn Olson

  • Jr. Member
  • **
  • Posts: 89
  • Wall Worm
    • Wall Worm
As a hint, I opened the preset source Max file ( _FP_Rocks_Presets ) and removed the first Empty entry, and it stopped crashing. I suspect the MAXScript just needs to check for an entry with no object assigned.
Shawn Olson
Product Management Team @ Autodesk for 3ds Max
Developer of Wall Worm Tools

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2457
Thanks for reporting this Shawn, I'll look into it. An empty entry is often used to create empty clusters in a distribution so it's not necessarily an error for them to be in the preset. If the library isn't able to open them though - then that's something we'll need to look into!
Paul Roberts
iToo Software

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2457
Confirmed! Out development team are looking into it. Thanks again for letting us know.
Paul Roberts
iToo Software