Itoo Software Forum

Author Topic: Material Browser and problems with tree-sizes in Custom Edit mode  (Read 2970 times)

ivo-ott

  • Newbie
  • *
  • Posts: 11
In first glimps the New Browser system is looking nice and hi-tech!
Then started to build my own library; working with it for some time I noticed like other ForestPro3 users, it's a very swetty and lo-tech job.
Mmmm.... in addition, some users have to turn hundreds and hundreds of previous ForestPro-version multisub-materials (built carefully in past years) manually to new Browser-system.
Dat-file editing ... ... thumbimage-generating-thumbs-saveing, paths-for-thumbs, path-for-library, name-in-library, tree-sizes - etc etc etc. One spelling-mistake in dat-file and nothing works! Checking, checking, checking.
What where you thinking guys??
Somebody has to earn living in everyday production work too. Most people has no time for this!!!
We need some kind of visual-and-idiot-proof-EDITOR urgently. This editor should automatically generate thumbs, generate proportionally correct sizes from bitmap images, in one word, this software saves correct things to correct places in simple and user friendly manner.
Or you should restore the tree-size-from-Planes-Material -thing.  Then it is possible to import or use the old materials.
Now everybody thinks twice when finds a new interesting bitmap, it's too complicated to add it to the library, it is too complicated to remember the process.
_________________________________________________________________

After going on and putting some other 100 trees, people etc to the new library  system I found out while testing, that there seems to be another problem.
First everything works ok and trees appear correctly in Browser and tree sizes are taken correctly from dat-file.
But it works only while generating trees in Generate-mode (by picking a closed spline)!
When  creating trees in Custom Edit mode (!and! Get-size-from-Library is ON!) nothing happens, all tree objects are the same size (2m to 3m units size).
What went wrong?
In hurry (you know, our always angry customers) I solved the problem by generateing a Forest object and exploded it to Custom mode.
I only needed to add some people in scene. It took me hours to find out, that it does not work. All people get 2x3 m fat and tall.

A bit angry now, it should be not that complicated!

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Material Browser and problems with tree-sizes in Custom Edit mode
« Reply #1 on: May 31, 2008, 01:20:29 PM »

Well, i was a bit worried because nobody was writting here about his experience with Forest 3. I was starting to think that the plugin was perfect !  ;D

Please, we need posts as this. We have introduced a lot of changes in the plugin, and the way of work with it have changed completely from Forest 2. We need to know if you like Forest 3, what features did you miss and what you would like to see in next releases. All suggestions to improve the software will be welcome.

You are right, an editor for the Library Browser would be nice. We have designed the library to use folders and standard text files (index.dat) instead custom binary files, so our users may edit them... but if you need to convert hundreds of materials, may be painful. We are now working in Forest 3.1, fixing some issues... we will put our team to work, to include a library editor for this release as well.

About getting the size on custom edition mode, is not as easy because if you have edited the trees, perhaps you don't want to modify their size. By default, on custom edition mode, the properties of each tree item are only modified by the user, not automatically. But, we will think on this... to find a fix that work in all conditions.

Carlos Quintero
iToo Software

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Material Browser and problems with tree-sizes in Custom Edit mode
« Reply #2 on: May 31, 2008, 05:03:49 PM »

Please, forget my last post about custom edition and autosize. I just noticed that creating a new tree always use the default values, not the size of the Geometry List. I was thinking on setting the size when we select an item from the Library (not the real issue).

We are going to fix it, as is not working as intended.
Carlos Quintero
iToo Software