Itoo Software Forum

Author Topic: Material optimizer doesn't work with CoronaPhysicalMtl  (Read 200 times)

Victor Vlasenko

  • Newbie
  • *
  • Posts: 3
Material optimizer doesn't work with CoronaPhysicalMtl
« on: January 21, 2022, 04:44:06 PM »
All simple - all in the topic name

Some additional thoughts:
1. Is it possible to add to the material optimizer option to select blending? Right now material optimizer creates forest color with "color" by default. But sometimes some other option is needed for a particular setup, like normal or additive and then we have to change it manually for all materials.

2. This one will be much more complex and not sure if it is doable, but maybe some checkboxes in the material rollout to replace blending at rendertime. Like replace "additive", "color" with "normal" blending for this particular forest object.
So - checkboxes of blending mode to replace and rollout with replace option.
This allows to reuse of the same source objects with the same materials in the scene, but have a different appearance.

3. Brightness adjustment in color correction is quite weird. Small values have almost no effect, while higher values make objects white instead of bright, or black instead of dark. It looks like objects lose contrast and saturation.


Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2762
Re: Material optimizer doesn't work with CoronaPhysicalMtl
« Reply #1 on: January 24, 2022, 12:47:20 PM »
Hi Victor,

Thanks for your message. I've passed your suggestions for improving the material optimiser on to our development team for consideration.

All the best,
Paul
Paul Roberts
iToo Software