Itoo Software Forum

Author Topic: missing maps - persistant  (Read 554 times)

TL1895

  • Sr. Member
  • ****
  • Posts: 296
missing maps - persistant
« on: September 20, 2017, 04:53:58 AM »
I've been getting this a lot but finally discovered the culprit to be FPP preset -  light mulch.
One map is simply named "glossiness.jpg" and the other is "normal.jpg"

Also should note that the auto-material is using the incompatible standard max normal bump rather than the V-ray normal bump.

Please advise, thank you,
TL1895
« Last Edit: September 20, 2017, 04:56:08 AM by TL1895 »

TL1895

  • Sr. Member
  • ****
  • Posts: 296
Re: missing maps - persistant
« Reply #1 on: September 20, 2017, 05:06:37 AM »
Actually, strangely the whole tree is using standard max materials instead of V-ray.
Why? Thanks.


Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1396
Re: missing maps - persistant
« Reply #2 on: September 20, 2017, 12:26:02 PM »
Hi,

Please double check, you're using the Material > Automatic Selector option (not Standard) - having the V-Ray assigned as the Production renderer, when importing it or select the VRay option.

All used maps in our presets are by default stored at:

C:\Program Files (x86)\Itoo Software\Forest Pack Pro\maps\Presets

Might be, that for some reason path to these assets are missing / not properly mapped under your 3ds Max's configuration accessible by Customize - Configure User Paths - External files and stored in the 3dsmax.ini. The .ini file is located by default here:

C:\Documents and Settings\<username>\Local Settings\Application Data\Autodesk\3dsmax\<max version>\enu\3dsmax.ini

Actually, it's not necessary to configure these paths manually. When Forest is loaded, it's checking if these paths exist and if not, all of them could be added automatically (the plug-in shows a warning message). If you marked previously the "Do not show this message again" check-box to disable that pop-up window, you can revert it to its default value (to pop-up) by setting the checkTexturePaths = 1 in the forestpack.ini configuration file located by default at:

C:\Users\<username>\AppData\Local\Autodesk\3dsMax\<maxversion>\ENU\en-US\plugcfg

Hope that helps.

Best regards,

TL1895

  • Sr. Member
  • ****
  • Posts: 296
Re: missing maps - persistant
« Reply #3 on: September 20, 2017, 01:13:46 PM »
That's all interesting, but it only happened with certain mulch presets.  I deleted the broken forest object, and made a new one and chose one of the chocolate mulch presets, and it came in correctly with V-ray material, as expected.  Yes, I have had it set to automatic and V-ray is always the scene rendered.  The other FPP objects all were coming in correctly, but suddenly this oddness occurred.
Unless someone broke into my studio and changed my scene, I see no reason for this to have happened in a few isolated cases, in a scene that's been fine for over a week.
I'll keep an eye on it and if it happens again, I'll post here.
Thanks,
TL1895

« Last Edit: September 20, 2017, 01:32:56 PM by TL1895 »

JTP Vis

  • Full Member
  • ***
  • Posts: 107
Re: missing maps - persistant
« Reply #4 on: November 15, 2017, 11:04:47 AM »
Sorry to resurrect an old post, but I have been making some changes to my library files, namely changing them to units m, and have come across some missing maps from your library files!

The file "fp_mulch_woodchips.max" has the following files missing:

     glossiness.jpg
     Normap.jpg

I have searched the iToo installation folder and they do not exist in there.

When I open the file "fp_mulch_mix.max" the textures named above are missing, and also the one below (as listed in the missing external files dialog):

     D:\Downloads\Assets\textures\UVW Patterns\custom_uv_diag.png

Do you know where or if these files are used, and if they are necessary, where I can get them from?

Cheers,

Bill

EDIT: So I looked a bit more into the files and found that they are associated with the default materials, so using v-ray will not be affected, but missing maps are never good for an official release of software!
« Last Edit: November 15, 2017, 11:13:43 AM by JTP Vis »

TL1895

  • Sr. Member
  • ****
  • Posts: 296
Re: missing maps - persistant
« Reply #5 on: November 15, 2017, 02:14:09 PM »

EDIT: So I looked a bit more into the files and found that they are associated with the default materials, so using v-ray will not be affected, but missing maps are never good for an official release of software!
Yes, well put.  Also it is quite bad for using 3rd party render farms...

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1396
Re: missing maps - persistant
« Reply #6 on: November 16, 2017, 05:36:08 PM »
Hi,

Big thanks for reporting this problem. First let me mention, that instead of modifying default libraries, I would suggest you create a copy - for example within the User's Libraries branch and edit such copy. If not, all changes will be overwritten by any the Forest updates.

Though during the import process of the preset, the material is always assigned from the material library (the one used in the scene file isn't used any time), we'll remove any materials from such scene. Once again, big thanks for your detailed feedback.

Best regards,