Itoo Software Forum

Author Topic: Missing maps when imported with FPP  (Read 352 times)

Panlayar

  • Newbie
  • *
  • Posts: 1
Missing maps when imported with FPP
« on: September 19, 2022, 10:26:30 AM »
Hello,

We currently have a problem with some Maxtrees, Globeplants and even the FP library that make our max to be extremely slow.
The original model (a bush for example from Maxtree v6 ) is mapped and work fine when imported directly into max, but when the same bush is imported by our FPP library, the maps are there too, and work, but the script "RelinkBitmap" by colin Senner say that all the maps are missing.
We usually work with A LOT of forest in our scene so thousand of maps are missing every time, and we do believe that this is the reason why every open/save files took 25/30 minutes for our biggest project and made us lose time.

• We already have our maps path in the external path library of 3ds max, so we really don't have any idea of the reason of this problem...
• We dont want to relink everytime we import a new model (but at the moment, we only find this method to fix our problem)

If someone have the solution, that could save us a lot of time !

Thx,
Guillaume

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1914
Re: Missing maps when imported with FPP
« Reply #1 on: September 19, 2022, 12:28:44 PM »
Hi Guillaume,

I'm sorry to hear you're facing these troubles. Well, it shouldn't be necessary to "relink" used textures. I would suggest you check the status by the Asset Tracking tool - if it says Found for those textures, there shouldn't be any problem with it (although it's not showing the correct folder). If wanted, you can map it to the "right folder" by right click on selected assets and choosing Set Path..., in Specify Asset Path you can map it to your folder location.

You can set the "default" folder by modifying the following registry key as needed:

HKEY_LOCAL_MACHINE\SOFTWARE\Itoo Software\Forest Pack Pro\TexturePaths


That should do the trick. Let me add, that generally, we recommend resolving all references used by Forest with the Asset Tracker to absolute UNC paths. It's not necessary, but usually, this way you avoid any texture path issues while using distributed rendering. The "default" file handling is controlled by 3ds Max and could be adjusted under Options - Preference Settings - File Handling - Convert file paths to UNC. This way all your scenes should use UNC paths.

Best regards,