Itoo Software Forum

Author Topic: no 2d trees for vray?  (Read 427 times)

grue

  • Full Member
  • ***
  • Posts: 106
no 2d trees for vray?
« on: July 21, 2023, 08:12:12 PM »
i imported 3 or 4 2d trees from the Forest Library to use in a forest object.  i would not see anything in the render. i'm using vray 6.x GPU.

i tried CPU vray and it rendered.

switched back to GPU and nothing.

in the slate material editor, i picked the material from the forest object and applied one of the multi-sub object materials directly to a new plane i drew in the scene. (i assigned the vray material, not the Forest Material to the new plane).

i got an error that the file format was not supported. i looked and the opacity maps for the various 2d trees are all .gif files.

i converted 1 .gif opacity map file to a .jpg, applied the vray material directly to the new plane and it rendered!

i converted all the .gif files in: C:\Users\xxxx\AppData\Local\Itoo Software\Forest Pack Pro\maps to JPG files. then i loaded those JPG files in place of the .gif files and tried to render the whole forest object of 2d trees and got these errors in the vray render error log:

Code: [Select]
13:03:36.214] Error : Export errors:
[13:03:36.216] Error : Unsupported material 'laurus_nobilis (Forest Material)'
[13:03:36.233] Error : Affected Nodes: Plane002
[13:03:36.246] Error : Affected Materials: forest_automat_C3349B20 (Multi/Sub-Object)
[13:03:36.258] Error : Unsupported material 'nyssa_sylvatica (Forest Material)'
[13:03:36.273] Error : Affected Nodes: Plane002
[13:03:36.289] Error : Affected Materials: forest_automat_C3349B20 (Multi/Sub-Object)
[13:03:36.303] Error : Unsupported material 'juniperus_communis (Forest Material)'
[13:03:36.318] Error : Affected Nodes: Plane002
[13:03:36.333] Error : Affected Materials: forest_automat_C3349B20 (Multi/Sub-Object)
[13:03:36.348] Error : Unsupported material 'pinus_sylvestris (Forest Material)'
[13:03:36.363] Error : Affected Nodes: Plane002
[13:03:36.379] Error : Affected Materials: forest_automat_C3349B20 (Multi/Sub-Object)
[13:03:36.394] Error : Unsupported material 'thuja_plicata (Forest Material)'
[13:03:36.408] Error : Affected Nodes: Plane002
[13:03:36.422] Error : Affected Materials: forest_automat_C3349B20 (Multi/Sub-Object)
[13:04:04.865] Error : 16 error(s), 0 warning(s)

so now is VRAY not able to work with Forest Material?

any other thoughts on working around this?  maybe i have to create new 2d trees and then apply those to the forest object in place of the ones that come in the 2d object library?

thanks

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 4449
    • iToo Software
Re: no 2d trees for vray?
« Reply #1 on: July 22, 2023, 09:27:48 AM »
Hi,

I'm afraid that 2D items are not supported for V-Ray GPU, or other GPU renderers.

Forest Material requires an specific code which runs at render time, but usually GPU renders doesn't allow to use third-party plugins.
ChaosGroup has implemented directly in their GPU engine some Forest features, but not this one.

I would suggest to use 3D items instead.
2D items was introduced for old render engines which had not instancing capabilities (as Scanline), but they are not very useful actually. New renderers are very efficient rendering 3D instances.

Futhermore, it's possible that we remove support for 2D items in upcoming Forest versions. This feature forces up to keep legacy code, and options in the user interface, which are rarely used.

Regards,
Carlos Quintero
iToo Software

grue

  • Full Member
  • ***
  • Posts: 106
Re: no 2d trees for vray?
« Reply #2 on: August 03, 2023, 06:10:15 PM »
sorry for late reply, yes it worked just fine using 3d models!  i guess i was stuck in "old fashioned" mode.  the moutain side must be like a square mile and even with camera visibility i though oh boy.  but nope, worked great.

RealViz

  • Sr. Member
  • ****
  • Posts: 351
Re: no 2d trees for vray?
« Reply #3 on: August 04, 2023, 07:05:21 AM »
Yes today there is no problem in 3D. In our last project we planted an area of 800km2 with the help of FP :-)