Itoo Software Forum

Author Topic: Octane Materials Missing  (Read 672 times)

JS4753

  • Newbie
  • *
  • Posts: 43
Octane Materials Missing
« on: August 29, 2016, 02:58:01 PM »
Hey,

I've got a problem using the Forest Pack presets (with Octane materials). When importing a preset from the library, allt he plants are rendering white/grey. I then checked the materials by picking them from the forest templates in the scene and noticed that there are Multi/Submaterials applied but they are all white glossy mix materials (see image attached). There is not one RGB image texture attached, that I could reconnect. But I checked, the maps are still there. Something must have changed, because I didn't have this problem some months ago. Can you help me with this problem?

Greetings :)

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1551
Re: Octane Materials Missing
« Reply #1 on: August 29, 2016, 03:38:55 PM »
Hi,

Thanks for contacting us. I can't reproduce these issues here with Octane 3 and the most recent versions of Forest Pack, however there was a change in materials to support Octane version 2.2 or greater because they no longer supported materials created in previous versions. Which version of Forest Pack and Octane are you using? Perhaps there's a compatibility issue,

Many thanks,

Paul
Paul Roberts
iToo Software

JS4753

  • Newbie
  • *
  • Posts: 43
Re: Octane Materials Missing
« Reply #2 on: August 29, 2016, 03:53:24 PM »
Hey,

thx for your fast answer. I am using the newest version of Forestpack (Forest Pack Pro v5.1.0) and Octane 2.23.2.

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1551
Re: Octane Materials Missing
« Reply #3 on: August 29, 2016, 07:00:18 PM »
Hi, Thanks for the info. I'm reading around on the Otoy Forum and it seems from this thread that materials that are compatible with 2.23.2 - 1.9 and earlier are not compatible with version 2.23.2 - 2.0 and later, so It may depend on which version you are running. The easiest solution therefore might be to update Octane, though this could break your existing materials for other objects.

Alternatively, I've attached our old Octane libraries to see if they help. To install them, copy and overwrite the existing libraries in your Forest Pack installation directory. By Default this is found at C:\Program Files (x86)\Itoo Software\Forest Pack Pro\matlib.

Many thanks,

Paul
Paul Roberts
iToo Software

JS4753

  • Newbie
  • *
  • Posts: 43
Re: Octane Materials Missing
« Reply #4 on: August 30, 2016, 10:49:55 AM »
Yayyyy your solution with overwriting the new material libraries with the old ones worked! Many thx!!!   :)

Yes I did'nt update to the newest Octane version yet because of the material chaos they created (can't do that meanwhile working on projects). I do not understand at all how they can bring a new Octane version without the possibility of internelly transforming their own materials (while you can transform vray and other materials). Bit angry about that   >:(

Wish u a nice day ;D

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1551
Re: Octane Materials Missing
« Reply #5 on: August 30, 2016, 11:33:34 AM »
Great!  Glad that the old materials are working for you. Let me know if there's anything else I can help with.

Cheers,

Paul
Paul Roberts
iToo Software

JS4753

  • Newbie
  • *
  • Posts: 43
Re: Octane Materials Missing
« Reply #6 on: August 30, 2016, 02:37:32 PM »
Actually I've got another question  ;) :

I am now working with Forest Pack to create a lawn. I am using big clumps in the middle (in the attached picture black) and smaller clumps at the edges (in the attached picture coloured). Now in some places I want to exclude areas from the lawn, therefor I added a spline area as exclude. Now u can see in the picture, that around those areas, there is no proper edge created with 0,5m (as it is at the edges of the lawn) but strange rectangular areas appear which are filled with the small clumps. They actually create a lot of geometry, that I want to avoid. Am I doing something wrong?

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1483
Re: Octane Materials Missing
« Reply #7 on: August 30, 2016, 03:37:47 PM »
Hi,

Would you mind to send us your scene to have a look at it here (hard to say what might be happening in your scene just from provided image)? Thanks in advance.

Is the Forest object / Distribution Map rotated? If so, aligning it to default world axis / setting the Density - Rotation to 0 might fix it.

Best regards,
« Last Edit: August 30, 2016, 04:21:09 PM by Michal Karmazín »

thanulee

  • Newbie
  • *
  • Posts: 7
    • Yell Images
Re: Octane Materials Missing
« Reply #8 on: August 31, 2016, 10:45:18 PM »
Same goes here. I switched to octane from vray, i pressed convert and no forest materials anymore. Any workaround on that? thanks

JS4753

  • Newbie
  • *
  • Posts: 43
Re: Octane Materials Missing
« Reply #9 on: September 01, 2016, 01:10:12 PM »
Hey,

I just send you the scene with the grass issue, maybe you can figure it out (probably sth stupid)  ;) The file is named "Scene Forest Grass"

The distribution map was not rotated...

Greetings

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1483
Re: Octane Materials Missing
« Reply #10 on: September 01, 2016, 01:25:32 PM »
Hi,

Thanks for provided scene. The Forest object rotation by 110º is causing such behaviour - to get the correct distribution it can be easily fixed by setting 0º.

Best regards,