Itoo Software Forum

Forest Pack => Forest Pro (*) => Topic started by: UC3472 on June 22, 2017, 03:47:37 PM

Title: Painfully Slow
Post by: UC3472 on June 22, 2017, 03:47:37 PM
Viewport performance with Forest Pro in 3DS MAX 2017 is painfully slow. I have some trees and some grass. I have to turn it off to do anything in the scene. You know what would be great, other than faster performance, a Forest Pro Listener.
Title: Re: Painfully Slow
Post by: Michal KarmazĂ­n on June 22, 2017, 04:48:25 PM
Hi,

Sorry to hear you're facing these troubles. Is that behaviour typical for any new scene or do you facing it with some specific one? Would you mind to send us (http://forum.itoosoft.com/index.php?topic=3648.0) your scene (ideally a simplified version of it) to have a look at it here?

As a first advice I would suggest you to switch from the Points-Cloud mode to Proxy (for example Plane or Pyramid).

Also please try to deactivate the Use DirectX acceleration option, to check if there is any improvement. The Use DirectX acceleration option you can find under the Display roll-out of the Forest object (where you can also switch between various display modes).

I should mention, even that all viewport rendering is handled by 3ds Max and Forest Pack has no influence on it, the problem eventually might be related to the graphics driver. Would you please try to change temporary the 3ds Max's display driver from "Nitrous" to "Legacy Direct3D", to check if there is some difference (Customize -> Preferences -> Viewports -> Choose Driver).

Thanks in advance for your collaboration, your feedback is very important to us.

Best regadrs,
Title: Re: Painfully Slow
Post by: UC3472 on June 23, 2017, 02:36:05 AM
It's not all scene, but it seems like if I have a few Forest objects it gets super slow. I mean, click and go get a coffee slow. I'll try what you suggested.
Title: Re: Painfully Slow
Post by: iToo on June 23, 2017, 09:16:57 AM
You know what would be great, other than faster performance, a Forest Pro Listener.

Please, would you detail ?
Actually Forest includes a lister (http://docs.itoosoft.com/forestpack/forest-lister), but i'm not sure if that's what you mean.

Thanks,
Title: Re: Painfully Slow
Post by: DRuivo on December 27, 2019, 04:08:29 AM
Hi, the same here, I have a TR1950X (not the fastest CPU in the world, I know) but it takes forever to pick an object and have forestpack displaying its properties in the modify tab.
I've been having this problem forever, changed video drivers, video cards (have a couple of 2080s to render with FStorm - We need materials for this!!!  :o ) and the modify toolbar takes 6-7s to load the FP properties.
I only have one FP in the scene, and if you are working with multiple FP objects in the scene, it can get pretty hectic, because between selecting and fine tuning all of them, you can waste hours in a day...

Is there no one else complaining about this - everyone  in my team has this issue, and even some collaborators that we work with complain about this.
I am happy to have you take a look at my scene, it is pretty frustrating at times when you have a deadline to accomplish to spend 2 hours of the day just selecting FPs for adjustments... :)

Memory and disk access should not be an issue either, packing an nvme sporting hundreds of gigabytes/s and 64Gb of fast 3200MHz RAM.


I'll be happy to provide you with a scene where this is happening, and this one is a tiny file, with a single FP, with 3 shrubs, of which 2 of them are being used in the FP and are pretty lowpoly AND proxy mode enabled - My computer has the obligation to handle this gracefully and yet it crawls like a zombie slug on a frozen lake.

https://we.tl/t-4B14HkkOok

Have a look at it and kindly let me know if there is any work around for this, given that I tried all suggestions stated in this post.
Title: Re: Painfully Slow
Post by: Michal KarmazĂ­n on December 27, 2019, 10:44:24 AM
Hi,

Thanks for the provided scene. Well, though it's a bit slower, there doesn't seem to be a very unusual lag (it may take some time to load all requested info to the UI and unfortunately, there isn't much more we do to speed it up).

A time ago, we've identified a "lag issue" related to having some graphical Java application running in the background. As advised in the "Forest Lag Issue (http://forum.itoosoft.com/index.php?topic=1452.msg6034#msg6034)" post, could you please "... check your background applications - close each one of them sequentially and check if something changes."?

Also, please feel free to have visible just some roll-outs - you can edit the Global Settings from the General rollout as desired (attaching screen-shot), which should help.

Thanks in advance for any further comments on this issue you can share about it with us / our user community (in case some user(s) will run into similar troubles).

Best regards,
Title: Re: Painfully Slow
Post by: iToo on December 30, 2019, 09:48:46 AM
Hi,

Although we cannot reproduce this problem here, it has been reported for several customers.
I will put here all information we have collected until now, in case it helps:

- Delay occurs in the initialization of the Forest rollups by 3DS Max.
Therefore the problem doesn't depend of the scene. It happens even editing an empty FP objecy in a new scene.

- It affects only to recent 3DS Max versions (probably 2019/2020), more specifically those using Qt libraries for the main interface.

- It seems to happen only with CPUs with high number of cores (as AMD Threadrippers or dual Xeons). Probably the delay initializing the interface is proportional to the number of virtual cores.

- We don't know if the problem is caused by Forest itself, or just the delay is more noticeable with our plugin, because it has tons of rollouts and UI controls.
It's diffcult to find other plugin with so many UI controls to compare. But hidding some rollouts in the Forest configuration (https://docs.itoosoft.com/forestpack/forest-plugin/general#General-Toshoworhidearollup) definitively helps.

This Autodesk article describes a very similar issue. We don't know if the proposed fix does any help. If so, please tell us:
https://knowledge.autodesk.com/support/3ds-max/troubleshooting/caas/sfdcarticles/sfdcarticles/3ds-Max-UI-lags-or-seems-sluggish-even-on-very-fast-multi-core-CPUs.html

I personally suspect there is some bug in the initialization of Qt controls, probably caused by a contention issue (https://en.wikipedia.org/wiki/Resource_contention) (when multiple threads wait until a resource is unlocked).
But this is only an idea... i can be totally wrong.

Just a test, if you have Hyperthreading enabled in the BIOS, it may be interesting to disable it temporary, and check if there is some difference (since Hyperthreading effectively doubles the number of virtual cores).

We continue investigating it...