Itoo Software Forum

Forest Pack => Forest Pro (*) => Topic started by: OS1884 on August 23, 2018, 09:35:22 PM

Title: Particle Flow instances disappearing
Post by: OS1884 on August 23, 2018, 09:35:22 PM
Hi,

was trying out the dist by particle flow and when I render most of the flow is correct but about 10% flicker on and off - anyone else get this?

Tried it with VRay and Redshift, and both show the same problem.

Particle flow itself is a simple system with particles using a lock bond on a noisy plane and a motion field moving them around.

Attached an example file - you can see them disappearing in the viewport...

Any ideas?

Thanks,

Steve
Title: Re: Particle Flow instances disappearing
Post by: Rokas on August 24, 2018, 08:09:07 AM
Hi Steve,

Thank You for reporting it. Confirmed and added to the to do list.
Title: Re: Particle Flow instances disappearing
Post by: OS1884 on August 24, 2018, 03:42:26 PM
Great, thanks Rokas!
Title: Re: Particle Flow instances disappearing
Post by: OS1884 on August 24, 2018, 03:46:03 PM
P.S.

As a request - it would be pretty useful for basic crowd animations/swarms of insects to have some control over the speed of the animation.

E.g. if it's moving slower the animation is slower, random offsets etc.

Seen people do it in Pflow but it's slow for lots of creatures, and Thinking Particles is a monthly outlay.

Thanks,

Steve

Title: Re: Particle Flow instances disappearing
Post by: Paul Roberts on August 24, 2018, 06:02:15 PM
Hi,

There is an Effect included in Forest Pack 6 called Frame by Particle Age that might help with this?

To use it you should:

1. Load the effect in the Effects rollout.
2. Change the animation mode to Frames from Map and set the start and end values as normal
3. Set FrameFromMapStart and FrameFromMapEnd to match the Start and End values set in step 1
4. Change the FPS setting to match your project settings.

Many thanks,

Paul
Title: Re: Particle Flow instances disappearing
Post by: OS1884 on August 25, 2018, 09:26:28 AM
Thanks Paul,

I'll take a look!

Cheers

Steve
Title: Re: Particle Flow instances disappearing
Post by: OS1884 on August 25, 2018, 01:07:58 PM
Hi,

that looks like it does the trick, thank you!

One question though - GPU renderers like Redshift don't support the animation controls (or vice versa)

But in Pflow itself I'm pretty sure I can get random offsets on instances using Redshift.

So is this something that Itoosoft needs to implement to work in ForestPro or Redshift or a bit of both?

Thanks,

Steve
Title: Re: Particle Flow instances disappearing
Post by: OS1884 on August 25, 2018, 01:12:02 PM
Hmm,

Actually don't think it works quite the way I needed - if the particles are all stopping and you can sync up the cycle then it fudges it, but I was after something more like if they stop/start/slow down/speed up it just alters the speed of the cycle.

Would look a bit weird for bipeds, but for insects it would be fine.

Cheers anyway!