Itoo Software Forum

Author Topic: Problem using GrowFX in FP  (Read 126 times)

JK4510

  • Newbie
  • *
  • Posts: 3
Problem using GrowFX in FP
« on: October 29, 2020, 11:58:04 AM »
Hi,
I'm hoping someone can help me out with the following issue:

I created a plant using growFX, the plant includes some instanced geometry.
When I scatter a single instance of this plant using Forestpack my rendertime is about 3 minutes.

However I want to add some variation so I've tried animating the seed of the GrowFX object and enabling Random Samples in forestpack (time offset 1, count 5).
I've also tried to copy the GrowFX object 5 times without adding animation to the seed and adding these 5 versions to the Forest object directrly.

In both cases the time to build light cache and prepasses goes up by a significant amount and the rendertime shoots up to about 10 hours.
I've noticed that my CPU usage goes down to 5% while it stays near 100% when using only a single instance of the plant.

Any help would be appreciated!


Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2669
    • iToo
Re: Problem using GrowFX in FP
« Reply #1 on: October 29, 2020, 01:43:40 PM »
Hard to say anything without seeing Your scene.
We can take a look in Your situation only if You attached or shared Your scene files.
Rokas
iToo Software

JK4510

  • Newbie
  • *
  • Posts: 3
Re: Problem using GrowFX in FP
« Reply #2 on: October 29, 2020, 03:15:31 PM »

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2669
    • iToo
Re: Problem using GrowFX in FP
« Reply #3 on: October 29, 2020, 03:43:06 PM »
I can reproduce the issue. Interesting. Investigating.
Rokas
iToo Software

JK4510

  • Newbie
  • *
  • Posts: 3
Re: Problem using GrowFX in FP
« Reply #4 on: October 29, 2020, 04:36:42 PM »
Thanks!

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2669
    • iToo
Re: Problem using GrowFX in FP
« Reply #5 on: October 30, 2020, 10:14:15 AM »
seems to be related to small buds geometry. If added prooptimizer modifer with 5% optimiziation to each of them it seems to go away.
Hope this helps for the time being.

We will still try to understand why this happens.
Rokas
iToo Software