Itoo Software Forum

Author Topic: Include areas doesen't work  (Read 703 times)

DE9014

  • Newbie
  • *
  • Posts: 4
Include areas doesen't work
« on: August 04, 2017, 05:57:12 PM »
In 3d Studio Max I'm trying to limit my grass to a certain area using a closed spline, I surround the area with it and add it to the Areas list with the "Adds a new spline area" picker.  I does nothing if "Include" is selected, if I select "exclude" then all the objects inside the spline disappear as they should.  I can't figure out what I'm doing wrong, please help! 

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 895
    • iToo
Re: Include areas doesen't work
« Reply #1 on: August 04, 2017, 06:09:51 PM »
Did You uncheck "surface area" object before using include spline?

What do You expect to see with Include mode?
Rokas
iToo Software

DE9014

  • Newbie
  • *
  • Posts: 4
Re: Include areas doesen't work
« Reply #2 on: August 04, 2017, 06:24:04 PM »
That was it, I never saw that in the documentation, thank you.

I'm having another problem with the density and scale of my objects.  I'm using the Disy 02 (large) preset from the library and when they come in they are huge.  If I scale them down to the correct size which is between 5%-10% I can't get the density high enough to complexity cover the ground.  Do you have any suggestions? 

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3328
    • iToo Software
Re: Include areas doesen't work
« Reply #3 on: August 05, 2017, 08:48:40 AM »
Hi, you can increase density setting lower values for Distribution->Density->X/Y Units. Just take care to not increase density over the default limits (you can find technical details here).

On the other hand, it's not normal that your preset is larger than normal. Please double check this checkbox is on: Customize->Units Setup->System Units Setup->Respect System Units in Files.

Carlos Quintero
iToo Software

FC1888

  • Jr. Member
  • **
  • Posts: 89
Re: Include areas doesen't work
« Reply #4 on: August 05, 2017, 07:43:56 PM »
Yeah, the scale of your scene is way too small..  which will not only cause problems for Forest Pack and for that matter, many other imported objects that are modelled to proper scale but also the lighting of the scene and it would also explain why no FP objects appear in your spline include area, because it is way to small.

DE9014

  • Newbie
  • *
  • Posts: 4
Re: Include areas doesen't work
« Reply #5 on: August 07, 2017, 04:58:43 PM »
I've checked my system units settings and "respect system units in files" is checked, units are set to 1.0=inches and the model was created in Revit at a 1-1 scale and exported as an FBX.  Only the objects I import from the library files are out of scale, models I merge in from other libraries are fine.   

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1548
Re: Include areas doesen't work
« Reply #6 on: August 08, 2017, 10:10:46 AM »
Hi,

It might be an import / units / rescaling issue as when using any "scaled surface(s)" Forest will inherit this scale (and that's not always desirable). In these cases, I would suggest you to apply the Reset XForm utility over that surface to reset its local coordinates & scale.

Generally, if you are using an imported surface, usually it's handy to apply the Reset XForm utility on it to "reset" it's local coordinates.

Hope that helps, but if the problem persist, please feel free to send us  your scene to analyse it here.  Thanks in advance.

Best regadrs,