Itoo Software Forum

Author Topic: Render Farm Problem Forest Pro 3.2.4  (Read 3579 times)

spike

  • Newbie
  • *
  • Posts: 34
Render Farm Problem Forest Pro 3.2.4
« on: December 24, 2009, 10:42:40 AM »
I saw your FAQ on the matter but still need help, my company recently bought Forest Pro for me, a licence is installed on my local machine to edit/render as necessary.
We understood that we only needed to install Forest Pro on a render farm (x6 machines) with no licensing or authorising, to render the scenes, any editing of the Forest Pro objects would need to be done on my local machine.
My IT dept. assures me that Forest Pro was installed as render slaves, but when I load a Forest Pro scene into Max 2008 on the render farm it constantly asks for a licence (see Forest Pro Activation Warning.jpg), this happens on all the render farm machines.

I have read the customising instructions and noticed that the registry has an entry like this:-

UseLicserver        REG_DWORD          0x00000000 (0)

Is this correct for a render node slave?

In HKEY_LOCAL_MACHINE\SOFTWARE\Itoo Software\Licenses\Products there is an entry

Forest Pack Pro 3.2.4    REG_DWORD       0x00000009(9)

Is this correct for a render node slave?

On a recent project I used the free version of F Pro and it worked fine?

kind regards

John
« Last Edit: December 24, 2009, 06:41:46 PM by spike »

yuv

  • iToo Software
  • Sr. Member
  • *****
  • Posts: 312
  • iToo Software - CEO
    • Itoo Software
Re: Render Farm Problem Forest Pro 3.2.4
« Reply #1 on: December 24, 2009, 05:36:43 PM »

Are you rendering the scene using backburner or opening it with 3dsMax ?

Forest Pro doesn't need any license for rendering nodes, but 3dsMax must be launched in non-interactive mode (from backburner or VRay distributed rendering). These registry keys don't have any effect on this mode.

The installer with "render-node" option only does a normal stand-alone installation, skipping the step of asking for a license. If you open 3dsMax in interactive mode on a render machine, it will work as a stand-alone workstation and therefore requesting a license.

There was a bug exactly as this in Forest 3.0, but only with Max 2009 and it was fixed in Forest 3.1. I just tested Forest 3.2.4, without licenses installed, in a clean Max 2008-64 installation and network rendering seems to work fine.

Daniel Quintero
Itoo Software
www.itoosoft.com
daniel@itoosoft.com

spike

  • Newbie
  • *
  • Posts: 34
Re: Render Farm Problem Forest Pro 3.2.4
« Reply #2 on: December 24, 2009, 06:41:16 PM »
Thanks, I will try in the New Year.

Merry Christmas