Itoo Software Forum

Author Topic: saving extremely slow - invisible corrupted forestobject?  (Read 1525 times)

link3d

  • Newbie
  • *
  • Posts: 38
saving extremely slow - invisible corrupted forestobject?
« on: February 05, 2013, 03:55:52 PM »
Hi,
we sometimes have scenes which save, merge and open extremely slow (1mb size +5 Minutes for saving), opening trackview also need ages. There seem to be some corrupted objects inside witch i suppose to be some corrupted forest thing. Attached is an scene like this - scene objects are deleted, but via ctrl+a you can select "something invisible notexisting".
Could somebody "debug" this scene or reports similar problems?
Matthias

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3156
    • iToo Software
Re: saving extremely slow - invisible corrupted forestobject?
« Reply #1 on: February 05, 2013, 04:48:28 PM »

There are some non-selectable objects in the scene, although they are not part of Forest, but helpers of Particle Flow.

They seem to come (in some way), from the Archmodels libraries. If that helps, i inspected them using Maxscript.

for obj in objects do print obj.name
"Archmodels55_01_arch20_027_07"
"Archmodels55_02_arch20_027_07"
"Archmodels55_03_arch20_027_07"
"Archmodels55_04_arch20_027_07"
"Archmodels55_07_arch20_027_07"
"Archmodels55_10_arch20_027_07"
"Archmodels55_13_arch20_027_07"
"Archmodels55_14_arch20_027_07"
"Archmodels55_25_arch20_027_07"
"Archmodels55_01_arch20_027_07"
"Archmodels55_02_arch20_027_07"
"Archmodels55_03_arch20_027_07"
"Archmodels55_04_arch20_027_07"
"Archmodels55_07_arch20_027_07"
"Archmodels55_10_arch20_027_07"
"Archmodels55_13_arch20_027_07"
"Archmodels55_14_arch20_027_07"
"Archmodels55_25_arch20_027_07"

OK

classof objects[1]
Particle_View

Carlos Quintero
iToo Software

link3d

  • Newbie
  • *
  • Posts: 38
Re: saving extremely slow - invisible corrupted forestobject?
« Reply #2 on: February 05, 2013, 05:32:54 PM »
hmm, so this seems to be off topic, sorry for that.

What do you think, even when deleting these objects max still is slow and the scene is not really empty. Max seems to keep something like a "missing path to some missing mesh". How do i get rid of that? When trying to export scene objets via "save selected objects" this corrupt information seems to infect te new scene....
Matthias

link3d

  • Newbie
  • *
  • Posts: 38
Re: saving extremely slow - invisible corrupted forestobject?
« Reply #3 on: February 05, 2013, 06:12:53 PM »
Carlos,
got a working tip from nicolas at the area. Used a "remove retimers" script and this scene seems to be fast again. Will test on other "corrupt" scenes...
Matthias

Pierre

  • Jr. Member
  • **
  • Posts: 79
    • Studiosezz
Re: saving extremely slow - invisible corrupted forestobject?
« Reply #4 on: February 06, 2013, 11:41:48 AM »
Hello,
i have this problem regulary for a year probably. Most of the time it happens when i merge a forest object with vrayproxy

Sometimes the following method works, you paste this line in the listener windows
trackViewNodes[#Max_MotionClip_Manager].track = copy trackViewNodes[#Max_MotionClip_Manager].track

then copy/paste:
gc()

If it doesn't work, you have to remove all the forest objects, merge your scene in a new one and recreate the forest from scratch...

Hope it will help you.
Pierre

Studiosezz PARIS
www.studiosezz.com

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3156
    • iToo Software
Re: saving extremely slow - invisible corrupted forestobject?
« Reply #5 on: February 06, 2013, 12:21:01 PM »

I think both are different issues, because the objects in the scene of Matthias are helpers of Particle Flow (Forest does not use P.Flow in any way).

Matthias, have you used Particle Flow as a scattering tool to distribute archmodels objects ? These helpers would come from here...

Pierre, if possible please send us a scene with the problem that you describe. The only point where Forest holds external objects, is in the layer "forest_templates" (when a model is loaded from the library). But this is a standard layer with the hidden flag on... if this is not the problem, i would like to investigate it.

Carlos Quintero
iToo Software

Pierre

  • Jr. Member
  • **
  • Posts: 79
    • Studiosezz
Re: saving extremely slow - invisible corrupted forestobject?
« Reply #6 on: February 06, 2013, 04:18:58 PM »
I will as soon I find again this problem. I'have always erased the concerned files for now.
Pierre
Studiosezz PARIS
www.studiosezz.com