Forest Pack > Forest Pro (*)

Scatter object on animated terrain

(1/2) > >>

I'd like to grow vegetation all over a animated robot.
But the scattered objects (plants) are allways change places when the robot's limbs move.

How to prevent that jittering please?
How to lock plant to the mesh all over the animation?

Michal Karmazín:
Hi Fabrice,

I'm sorry to hear you're facing trouble with it. We modified the UV mode some time ago to adapt better to the animated deformation of used surfaces (where the poly-count and UV mapping don't change). If you encounter any issues with it, would you mind send us your scene to check it here?

Let me mention, that for some scenarios (especially when using the UV mode and dealing with deformed UV space over time), the workflow described in the following "Scattering on the animated surface" post can be helpful.

Thanks in advance for any further comments on this issue you can share with us or our user community (in case other users encounter similar issues).

Best regards,

Here's the scene (Max 2021 + FP 7.4.3).

PS : I know I can achieve this with tyflow but I'd like to do it with FP to take advantage of it's scattering capacity

Just torn off collisions and increase the density to e.g. 650cm...

edit: see attach.

Michal Karmazín:
Thanks for the provided scene. Exactly, it's being caused by the Distribution > Collisions feature - once disabled, it works just fine. Please find attached the modified scene. I hope that helps.

Best regards,


[0] Message Index

[#] Next page

Go to full version