Itoo Software Forum

Author Topic: Set to X-ref to library - presets problem  (Read 659 times)

JTP Vis

  • Full Member
  • ***
  • Posts: 107
Set to X-ref to library - presets problem
« on: May 26, 2015, 01:57:34 PM »
Hi,

We've just noticed a problem with the preset libraries not being able to be set to X-Ref to library. We want to be able to set everything to X-Ref, so that it keeps our file sizes down, but some of the iToo presets do not allow this to work! We are currently using 4.3.6 and I know that there is an update available, but as we are exceptionally busy at the moment and don't want to have to upgrade the plugin if we have to right now I thought I should ask.

The problem seems to be with some of the "Forest Library - Presets." The library "Gravel" works fine, and allows the setting of either "Merge into scene" or "XRef to library", but none of the other preset libraries allow you to set this. Is this deliberate? Can it be changed from the User end?

Cheers,

Bill

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3148
    • iToo Software
Re: Set to X-ref to library - presets problem
« Reply #1 on: May 26, 2015, 02:35:37 PM »
Hi,

Yes, we decided to disable XRef for all presets. But there is a good reason for that: in this way we can modify these presets on Forest updates (i.e. optimize them, update materials, etc), while keeping the compatibility with existing scenes. If not, a same scene would look different depending of the Forest version used.

Anyway you can enable the XRef option easily, editing the index.xml (in the library folder) and setting xref="1" in the first line (it is set to 0 by default).
Instead modifying the default libraries, i suggest you create a copy in the User's Libraries branch and edit it. If not, all changes will be overwritten by the Forest updates.

In Forest 4.3.6 the "Gravel" library could be xref'd just by a mistake. We disabled the XRef option in the latest releases.
Carlos Quintero
iToo Software

JTP Vis

  • Full Member
  • ***
  • Posts: 107
Re: Set to X-ref to library - presets problem
« Reply #2 on: May 26, 2015, 06:02:13 PM »
Seriously...

BEST CUSTOMER SUPPORT EVER!

So quick and helpful.

I'll probably make a central copy of the presets then and unlock them all as they are making our Max files HUGE!.

Cheers again for the help.

Bill

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3148
    • iToo Software
Re: Set to X-ref to library - presets problem
« Reply #3 on: May 26, 2015, 06:21:14 PM »
Many thanks for your kind words. Glad I could help out. :)
Carlos Quintero
iToo Software