Itoo Software Forum

Author Topic: Why the Forest objects can’t be displayed in box mode ?  (Read 1018 times)

cc8boy

  • Sr. Member
  • ****
  • Posts: 276
  • I'll do my best.Welcome to www.c7design.cn .
    • C7design
Why the Forest objects can’t be displayed in box mode ?
« on: November 18, 2014, 07:25:24 AM »
Hi iToosoft,
Why the Forest objects can’t be displayed in box mode ?
All the forest objects were set to display in point cloud mode in my large scene. And I turned the viewport mode from shading mode to Bounding Box mode. But I found all the forest objects are still displayed in point cloud mode, not in Bounding Box mode, why?

Another problem is,
I put many forest objects in my Xref Scenes, I tried to unchecked the "display visible" in Xref scene menu. All the Xref Scenes were hidden. But when I open my main scene again, all the Xref Scenes will show up again ? I want to keep the Xref Scenes hiding . How can I do that ?
(MAX2012 64bit)
« Last Edit: November 18, 2014, 07:37:46 AM by cc8boy »
We are working hard in virtual effects in 3DSMAX. Welcome to our website in China.

IT1371

  • Full Member
  • ***
  • Posts: 135
Re: Why the Forest objects can’t be displayed in box mode ?
« Reply #1 on: November 18, 2014, 08:57:10 AM »
How about limiting it in the display parameter? I don't see why you need it visible in viewport after you set it up.

cc8boy

  • Sr. Member
  • ****
  • Posts: 276
  • I'll do my best.Welcome to www.c7design.cn .
    • C7design
Re: Why the Forest objects can’t be displayed in box mode ?
« Reply #2 on: November 18, 2014, 09:07:46 AM »
How about limiting it in the display parameter? I don't see why you need it visible in viewport after you set it up.
I've limited the display parameters of the forest objects. I set the point cloud global and local density to 1%(it can not be set to 0%).
Now I want them invisible in Bounding Box of viewports mode.
And I want them keep invisible in Xref Scenes even when I reopen the main scene. But I want them visible in final render buffer.
We are working hard in virtual effects in 3DSMAX. Welcome to our website in China.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3328
    • iToo Software
Re: Why the Forest objects can’t be displayed in box mode ?
« Reply #3 on: November 18, 2014, 10:35:01 AM »
Quote
Why the Forest objects can’t be displayed in box mode ?
All the forest objects were set to display in point cloud mode in my large scene. And I turned the viewport mode from shading mode to Bounding Box mode. But I found all the forest objects are still displayed in point cloud mode, not in Bounding Box mode, why?

It seems a bug specific of Max 2012. I can reproduce the problem here, but only with Max 2012. Max 2011, 2013, 2014 and 2015 work fine.

Quote
I put many forest objects in my Xref Scenes, I tried to unchecked the "display visible" in Xref scene menu. All the Xref Scenes were hidden. But when I open my main scene again, all the Xref Scenes will show up again ? I want to keep the Xref Scenes hiding . How can I do that ?

Similar problem, but in this case the bug is present in all Max versions above 2012. Instead, Max 2011 and before work fine. I can reproduce the problem with any XRef scene, not only using Forest.

I'm afraid both are Max bugs, we cannot do anything about it.
Carlos Quintero
iToo Software

cc8boy

  • Sr. Member
  • ****
  • Posts: 276
  • I'll do my best.Welcome to www.c7design.cn .
    • C7design
Re: Why the Forest objects can’t be displayed in box mode ?
« Reply #4 on: November 18, 2014, 12:08:19 PM »
Similar problem, but in this case the bug is present in all Max versions above 2012. Instead, Max 2011 and before work fine. I can reproduce the problem with any XRef scene, not only using Forest.

I'm afraid both are Max bugs, we cannot do anything about it.

Oh my god,Ah! That's a terrible problem! May I ask how to combine the complex scenes in MAX 2012 or above versions of MAX but keep the viewport clean ? I would not like to merge all scenes to one MAX file. Maybe this is not a question about iToosoft. But Can you give me some suggestions?
« Last Edit: November 18, 2014, 12:11:04 PM by cc8boy »
We are working hard in virtual effects in 3DSMAX. Welcome to our website in China.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3328
    • iToo Software
Re: Why the Forest objects can’t be displayed in box mode ?
« Reply #5 on: November 18, 2014, 12:31:23 PM »
In a quick search, i found a script that solves partially the problem. Probably there are other workarounds out there, although i don't know them:

http://forums.cgarchitect.com/75365-xrefdisplayfix-fix-xref-scenes-box-visible-display.html
Carlos Quintero
iToo Software

cc8boy

  • Sr. Member
  • ****
  • Posts: 276
  • I'll do my best.Welcome to www.c7design.cn .
    • C7design
Re: Why the Forest objects can’t be displayed in box mode ?
« Reply #6 on: November 18, 2014, 12:58:58 PM »
In a quick search, i found a script that solves partially the problem. Probably there are other workarounds out there, although i don't know them:

http://forums.cgarchitect.com/75365-xrefdisplayfix-fix-xref-scenes-box-visible-display.html

Thank you very much. I think I should abandon using Nitrous sometime.
We are working hard in virtual effects in 3DSMAX. Welcome to our website in China.