Itoo Software Forum

Author Topic: Tint by Boundary doesn't work  (Read 753 times)

HK4606

  • Newbie
  • *
  • Posts: 20
Tint by Boundary doesn't work
« on: June 12, 2016, 10:57:29 PM »
Hello,

Tried to use Tint by Boundary effect, but I didn't succeed. I followed the instructions from the tutorial (https://www.itoosoft.com/tutorials/tutorial_introduction_to_effects.php?back=page%3D1), but didn't get the tint effect.
The same problem I've got with Tint by Object effect.

Tried to use different renderers (Scanline, Vray, Corona) - result is the same

Max 2014, FP 5.0.5

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1609
Re: Tint by Boundary doesn't work
« Reply #1 on: June 13, 2016, 10:16:20 AM »
Hi,

This could be due to a small bug in the most recent version. Some values such as distance to area are only computed if they're needed for performance reasons. For the next release we've modified the code to make sure it is also calculated when using Effects. As workaround in the meantime you can turn on Falloff->Distance or Scale and set some of the distance parameters greater to zero and this will trigger the distance compute function and your effect should work correctly.

If this doesn't help please send me a sample scene of your setup and I'll take a closer look.

Many thanks!

Paul
Paul Roberts
iToo Software

HK4606

  • Newbie
  • *
  • Posts: 20
Re: Tint by Boundary doesn't work
« Reply #2 on: June 18, 2016, 08:34:49 AM »
Hi

Thanks for your respond!

I tried the way you suggested using falloff density and scale enabled, but didn't get the result either. Also I tried FP 5.0.7 version and didn't succeed with that too.

So, here is my example scene with this issue.

Can I ask you to share example scene where tint effect is working on your side? I would be not surprised if I missed something important from the tutorial :)

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1609
Re: Tint by Boundary doesn't work
« Reply #3 on: June 19, 2016, 12:00:03 PM »
HI!

Thanks for the file, I can see the issue. The colour mode in the Forest Map was set to Colour which will work fine if you want to use the boundary to tint maps but doesn't work when using it as a mask because the output will remain white (a colour's value is not affected in this mode..Instead change the mode to Normal so that the map outputs the colour set in the Forest Effect.



I've attached a revised version of your file. I hope that helps, please let me know if you have any further questions.

Many Thanks,

Paul
Paul Roberts
iToo Software

HK4606

  • Newbie
  • *
  • Posts: 20
Re: Tint by Boundary doesn't work
« Reply #4 on: June 19, 2016, 02:32:40 PM »
Thank you very much! It works! It still works only if falloff density or scale is active, but it's already can be used!

As I said, I can and I've missed important detail from the tutorial video :). Just wandering if I'm not the only one who missed it, because by default blending mode set to color. May be it would be good to add the note about it to this tutorial.

P.s You attached not changed file - blending mode is still Color there, so I attached file with blend mode set to normal if someone else will want to use it ;)

Thank you!

HK4606

  • Newbie
  • *
  • Posts: 20
Re: Tint by Boundary doesn't work
« Reply #5 on: July 07, 2016, 07:46:44 PM »
With new FP 5.0.8b these effects work well with no need to activate falloff parameters.
Thanks a lot!

HK4606

  • Newbie
  • *
  • Posts: 20
Re: Tint by Boundary doesn't work
« Reply #6 on: July 07, 2016, 10:42:01 PM »
Just noticed that Tint by Boundary works only with include areas. Is it possible to make it work with exclude areas too?

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1555
Re: Tint by Boundary doesn't work
« Reply #7 on: July 08, 2016, 12:18:48 PM »
Hi,

Yes, it's possible to evaluate both fpItem.areaIncDistance & fpItem.areaExcDistance Forest's attributes. Attaching modified effect. If wanted the DistanceToEdge parameter can be divided into DistanceToEdgeInc & DistanceToEdgeExc to have a separate control of those.

Hope you'll find it useful.

Best regards,

HK4606

  • Newbie
  • *
  • Posts: 20
Re: Tint by Boundary doesn't work
« Reply #8 on: July 12, 2016, 02:14:12 PM »
Thank you very much!