Itoo Software Forum

Author Topic: Vray Embree + Forest Pack = massive rendertime?  (Read 1043 times)

SozoDigital

  • Newbie
  • *
  • Posts: 11
Vray Embree + Forest Pack = massive rendertime?
« on: August 09, 2015, 07:30:43 AM »
Hi all,

I've done a quick search and didn't find anything really related, so I'm posting this here.


I noticed a massive render slowdown when shifting a scene with Forest Pack 4.40 and a good number of VrayProxies for trees etc from Max 2014, Vray 2.50.1 over to Max2015 SP3 Vray 3.2.03.

Here are the Rendertimes:

Max2015 SP3 Vray 3.2.03 Embree enabled: ~25min/Frame; LC: ~14 min

Max2015 SP3 Vray 3.2.03 Embree disabled: ~4min/Frame; LC: ~2 min

For comparison:
Max 2014, Vray 2.50.1: 6.30min/frame: LC:2.45min

This is for a fly-by animation of a stylized forest scene, btw. In terms of render settings, nothing changed from Max 2014, Vray 2.50.1 to Max2015 SP3 Vray 3.2.03, except that Embree is enabled by default in Vray3, so I was fairly quickly able to pinpoint it to "Embree" being enabled or disabled. Not sure if this really has to do anything with Forest Pack, but maybe with the VrayProxies? Has anyone else noticed anything similar?

Cheers!

SozoDigital

  • Newbie
  • *
  • Posts: 11
Re: Vray Embree + Forest Pack = massive rendertime?
« Reply #1 on: August 10, 2015, 07:13:18 AM »
As a quick update, here's some info I got from Vlado over at the ChaosGrp forum:

>> Embree has a severe problem with poor multithreaded memory allocation when building its acceleration structures (and this is a process that needs to be done when the proxy is loaded during rendering), although it is typically a lot faster for raytracing. Normally it's not a big issue, but it shows up in some scenes. We still haven't gotten to rewriting that part of Embree.

Finally, Forest Pack needs to be recompiled to take advantage of the proxy speed up improvements in V-Ray 3.20.03 specifically - not sure if they guys at Itoo managed to do that.
<<

Cheers!

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1490
Re: Vray Embree + Forest Pack = massive rendertime?
« Reply #2 on: August 10, 2015, 07:40:28 AM »
Hi,

Actually, we've been informed by Chaos Group team about changes introduced in the V-Ray 3.20.03 and we'll recompile Forest Pack with that latest V-Ray release soon.

Anyway, we've been doing several tests with VRayProxies distributed by Forest Pack Pro 4.4.1 on 3ds Max 2015 SP3 & V-Ray 3.20.03, but we can't reproduce any similar troubles with the Intel Embree raycaster.

In case of calculating the motion blur, did you try to disable the Use Embree for motion blur if there is any difference? Enabling Conserve memory may slow things down, but in any case there shouldn't be such a huge difference.

As you've mentioned, that "... This is for a fly-by animation ...". Are you using the Single frame mode or the Fly-through (Use camera path ON / OFF?) for the Light cache engine? Please feel free to check this related post "Vray: animation with light cache along path / multiframe incremental".

Best regards,

SozoDigital

  • Newbie
  • *
  • Posts: 11
Re: Vray Embree + Forest Pack = massive rendertime?
« Reply #3 on: August 15, 2015, 12:05:41 PM »
Sorry for the much delayed response.


Thank you very much for your input and the info. I'm not using any motion blur during rendering and do have both Fly-through/Use Camera Path enabled for the light cache. There are about 10 or more high -res trees and bushes being scatterd by ForestPack as VRayProxies.

Cheers!

LightSyndrome

  • Newbie
  • *
  • Posts: 27
Re: Vray Embree + Forest Pack = massive rendertime?
« Reply #4 on: August 17, 2015, 03:37:54 PM »
Hi all


I have the same issue but other problem too.

My max crush...