Itoo Software Forum

Author Topic: White pixels on Forest grass with edge mode enabled  (Read 640 times)

Ruud3DV

  • Newbie
  • *
  • Posts: 18
White pixels on Forest grass with edge mode enabled
« on: December 19, 2015, 03:57:53 PM »
White pixels appear at the border of Forest grass with edge mode enabled.
These pixels appear outside the surface, and it looks like it has the shape of the grass that should have been trimmed there.
The effect increases with distance, when moving the camera closer the effect moves with it. A closeup doesn't show it.

Is there a solution for this?

3dsmax 2016 x64 on Win 7, Vray 3.20.03, Forest Pro 4.4.1
No camera/lens/atmospheric effects used
Forest grass preset 'Cut grass filed 03 (large)' was used, with a flat surface area.

Ruud3DV

  • Newbie
  • *
  • Posts: 18
Re: White pixels on Forest grass with edge mode enabled
« Reply #1 on: December 19, 2015, 05:06:27 PM »
I think I found the cause, it happens with Forest Geometry Properties: Global Scale > 100.
Also, when Global Scale < 100, the grass doesn't fit the entire surface anymore.

The workaround for now would probably be to scale the individual geometry to the desired size, instead of using global scale. Will try this.

Ruud3DV

  • Newbie
  • *
  • Posts: 18
Re: White pixels on Forest grass with edge mode enabled
« Reply #2 on: December 19, 2015, 05:28:32 PM »
Another update: it's not just Global Scale, but it amplifies the problem. Even on 100% it shows white pixels in the distance.
Just when it's > 100% it shows more in the foreground. Anyway: if Global Scale isn't 100% the edge mode will not work as expected, when < 100% it won't fill the surface entirelyand when > 100% it will go beyond the surface.

I've attached an example with Global Scale at 100% and one at 500% to illustrate this.
« Last Edit: December 19, 2015, 06:02:13 PM by Ruud3DV »

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1490
Re: White pixels on Forest grass with edge mode enabled
« Reply #3 on: December 21, 2015, 09:55:59 AM »
Hi,

Looks like, V-Ray exceeded its default transparency limit (which could cause similar render artefacts). I would suggest you to increase Global switches - Max transp. levels (default value is 50). Sometimes may be necessary to modify Secondary rays bias also.

As mentioned in this "Some key notes about Areas->Boundary Checking->Edge mode" related post: "In the case of very high density scatters (like dense grass), many overlapping objects could be generated and V-Ray may exceed its default transparency limit (which can cause render artifacts)". You can find there how to fix it (use lower Density values / increase VRay's Max transp. levels).

Best regards,