Itoo Software Forum

Author Topic: xFrog Allium Onion Plant head comes out Black in render ???  (Read 523 times)

3dvisuals.co.uk

  • Newbie
  • *
  • Posts: 25
xFrog Allium Onion Plant head comes out Black in render ???
« on: September 15, 2015, 04:43:50 PM »
I purchased an xFrog plant (an Allium Onion Plant) and when I use FPP to scatter those objects around a planting area, the materials are black for the head/petal area.

Please see attached test render.

Please can you advise ?  The models are fine on their own - only when used within FPP do I get this error, so it is something to do with FPP and not the model at fault (of course, I may be doing something wrong.....).

Thank you.

3DS Max Design 2014, V-Ray 3.20.03 & FPP 4.4.0.

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1490
Re: xFrog Allium Onion Plant head comes out Black in render ???
« Reply #1 on: September 15, 2015, 05:51:44 PM »
Hi,

XFrogPlants for 3ds Max included formerly just Standard materials for the Scanline renderer (and this could possibly cause lightning issues with other render engines like V-Ray). We highly recommend you to get the best results with Forest Pack, to run the Material Optimizer once you import the XFrogPlants models into the scene. With this utility you can benefit of improved render times and realistic look only with a single click. To use it open the Materials rollup in your Forest object and press the Optimize Materials button. In your case please convert materials to the native VRayMtl.

Also, would you mind to double check, you have the path to used textures properly configured? XFrog Catalog does not configure texture paths, this is responsibility of the user.

Usually the texture paths must be added to the Max configuration, using Customize->Configure User Paths->External Files, but XFrog uses a texture folder for each model, so the number of paths may be very high, when using multiple libraries.

In this case we suggest to copy all textures in an unique folder, adding the folder to User Paths. To help you with this process, we have written the "XFrog Texture Maps Collector" Max script that collects all textures with a single click. You can download the script from here.

Unzip the .ms file and launch it from MAXScript->Run Script. Select the source and destination folders, and click Collect to copy the files. When finished, add the destination path to the Max's configuration (User Paths).

Feel free to check more information about Forest Pack support for XFrog models here.

Best regards,

3dvisuals.co.uk

  • Newbie
  • *
  • Posts: 25
Re: xFrog Allium Onion Plant head comes out Black in render ???
« Reply #2 on: September 15, 2015, 09:14:18 PM »
Hi Michal,

And thanks for your reply.

The issue isn't the map paths - I purchased this single flower from TurboSquid and manually put maps into my maps folders each time I buy from them.

Furthermore, when I test the materials by opening the .max files for the model, things are fine.

It is only when I merge this flower into my scene and use it as a custom object in FPP that I then get these problems.  For example, I have several FPP objects in my scene, and they are all working fine - it's just this particular flower.

Please note that I did do an Optimize, and that this particular flower is VRay ready.

Any other ideas ?

Thanks.

PS - Please see what my material slot looks like for this object - notice the black areas ??  (this doesn't make sense to me )
« Last Edit: September 15, 2015, 09:16:23 PM by 3dvisuals.co.uk »

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1490
Re: xFrog Allium Onion Plant head comes out Black in render ???
« Reply #3 on: September 16, 2015, 10:15:19 AM »
Hi,

I would suggest you to check if there is any Normal Bump map connected to the Bump map slot of the VRayBumpMtl material used in your scene. In some cases, that might cause unwanted artefacts.

Changing the Normal Bump map to VRayNormalMap should solve the issue. Actually, as you can double check on our forum - there is already a thread regarding this topic.

Anyway, please feel free to send us your scene to support@itoosoft.com and we´ll check it. In case of big file size, please use a web sharing service as WeTransfer. Also please specify Forest Pack Pro / 3ds Max / renderer releases used. Thanks in advance.

Best regards,

3dvisuals.co.uk

  • Newbie
  • *
  • Posts: 25
Re: xFrog Allium Onion Plant head comes out Black in render ???
« Reply #4 on: September 16, 2015, 03:17:14 PM »
Hi Michal,

I fixed it.

I inspected the materials for this xFrog plant, and those Normal  Bumps were set to VRayNormalMaps, so I couldn't change them.

What I did was simply remove the bump - at the viewing distances involved, I can live without it.

Long term, it'd be nice to have a solution though :)

Many thanks for all your help though Michal - your guidances helped.