Itoo Software Forum

Author Topic: Xfrog trees have no leaves after 'Optimize' material  (Read 1149 times)

RobH2

  • Newbie
  • *
  • Posts: 44
  • Who is staring at the sea is already sailing a bit
    • NVision4D
Xfrog trees have no leaves after 'Optimize' material
« on: May 12, 2015, 10:42:15 PM »
I've purchased an Xfrog tree library which is from Volume I and has standard materials instead of V-Ray materials. I use V-Ray.

So, I 'Optimized' the material from the Forest 'Material' rollout. I made sure that the material nodes were all VRayMtl instead of Standard and they are.

However, when I render, the trees have no leaves. Only the bark renders. I think I've followed the 'Optimize' directions properly. What could I possibly have turned off?

ForestPack Pro 6.3.1, RailClone 4.2.13, 3ds Max (Max 2021), GIGABYTE X570 AORUS x570 Master Motherboard,
Ryzen 9 3950x CPU, Noctua NH-D15S CPU Cooler, 128 GB G.SKILL Trident Z Neo DDR4 Ram, Sabrent Rocket NVMe 4.0 M.2 drives

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1764
Re: Xfrog trees have no leaves after 'Optimize' material
« Reply #1 on: May 13, 2015, 09:41:05 AM »
Hi,

It sounds like, 3ds Max can't find all textures needed. You can double check it under the Asset Tracking tool - for proper rendering the status should say OK / Found (most probably you'll see File Missing and the right path to these assets needs to be mapped).

I would suggest you to check you've mapped the path to the folder containing texture files by looking at External Files path list under Customize - Configure User Paths.

In case of Xfrog models the folder structure is "more complicated" and you need to configure it by yourself, as mentioned on our web site for Forest Pack support for Xfrog models:

"XFrog Catalog does not configure the texture paths, this is responsibility of the user.

Usually the texture paths must be added to the Max configuration, using Customize->Configure User Paths->External Files, but XFrog uses a texture folder for each model, so the number of paths may be very high, when using multiple libraries.

In this case we suggest to copy all textures in an unique folder, adding the folder to User Paths. To help you with this process, we have written a Max script that collects all textures with a single click. You can download the script from here.

Unzip the .ms file and launch it from MAXScript->Run Script. Select the source and destination folders, and click Collect to copy the files. When finished, add the destination path to the Max's configuration (User Paths)."


We understand, that in combination with the XFrog Texture Maps Collector the installation process is quite complex, but unfortunately as these libraries are done by third party company (Xfrog Inc.) we can't modify it's folder structure. Thanks for your comprehension.

Best regards,