Itoo Software Forum

Forest Pack => Forest Pro (*) => Forest Pro beta => Topic started by: Dragan on February 22, 2018, 04:48:15 PM

Title: Cars along spline
Post by: Dragan on February 22, 2018, 04:48:15 PM
Hi,
How to set up Cars along spline effect in FP6 beta
I cant get it to work :(
Title: Re: Cars along spline
Post by: Michal KarmazĂ­n on February 23, 2018, 09:46:23 AM
Hi,

Big thanks for reporting it. There is a problem in the current beta, that prevents you using IF statements when assigning a value to a vector (used by this effect). We'll check how that can be fixed (it'll need to be investigated more in deep by our main developers).

Thanks your speedy feedback, it's very important for us.

Best regards,
Title: Re: Cars along spline
Post by: Dragan on March 17, 2018, 07:29:49 PM
Hm, I have problems with beta FP 6.0.2 and this effect. Now effect will appear as good but any change on effect parameters will translate whole system along X or Y axis (not sure now)... 

Best Regards
Dragan
Title: Re: Cars along spline
Post by: Dragan on April 23, 2018, 09:41:11 AM
Please check the last beta. When effect is active, switching to Custom Edit seams to break all position set by effect....
Title: Re: Cars along spline
Post by: Rokas on April 23, 2018, 04:12:26 PM
Thank You, Dragan.
Title: Re: Cars along spline
Post by: Rokas on May 10, 2018, 04:36:26 PM
Fixed. Please try now.
Title: Re: Cars along spline
Post by: Dragan on May 10, 2018, 05:12:51 PM
Overall working good now although some item was lost when switched to Custom Edit... (no camera selected to avoid clipping)
Thank You
Title: Re: Cars along spline
Post by: Dragan on May 10, 2018, 05:24:23 PM
It seems to be happening when Empty Spaces is active...

Also, when effect is ON and multiple items are selected then move some of item remain...

Title: Re: Cars along spline
Post by: amitgedia on May 13, 2018, 12:25:25 PM
Hi,
did you check with their pivots position...??? check if they have their pivots centered or somewhere else...
Title: Re: Cars along spline
Post by: Dragan on May 13, 2018, 12:52:52 PM
Pivot are ok, centered and oriented along x axis. As I recall now, I think since beta released I had to rotate in transform for 90 deg. 

But overall I have problem when  switch to Custom Edit in fresh scene, not just with CarAlongSpline effect.



Title: Re: Cars along spline
Post by: Dragan on May 14, 2018, 08:31:28 AM
hm... In FP6 distribution path is different, it follows the X axis...

If Car items are set as before they will follow path on X axis so all items should be rotated for 90deg.
At first they all set ok but I think effect expressions should be switch from x to y orientation...  :-\