Itoo Software Forum

Author Topic: FP 7, render mask problem on Vray 5  (Read 1474 times)

TQ2762

  • Newbie
  • *
  • Posts: 21
FP 7, render mask problem on Vray 5
« on: February 01, 2021, 02:25:37 PM »
Hello,

I had a problem on one of my project, when i had to select 1 FP object to render mask on Vray 5 (A FP with trees, separate from a building). The id object with multimatte didn´t work either, and in the end i had to set a wirecolour on the FP and everything else was pure black.

Since i cannot share the image or files, i´ve tried to replicate the problem with a simple scene and it is not working also. When i select "render mask" with the green box objects on the scene, it selects the other FP object (Pink boxes), just like my project scene.

The files and image are attached.

TQ2762

  • Newbie
  • *
  • Posts: 21
Re: FP 7, render mask problem on Vray 5
« Reply #1 on: February 01, 2021, 02:26:00 PM »
Here is the image

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 3262
    • iToo
Re: FP 7, render mask problem on Vray 5
« Reply #2 on: February 01, 2021, 03:04:14 PM »
Confirmed. Thank You for reporting it.
Rokas
iToo Software

TQ2762

  • Newbie
  • *
  • Posts: 21
Re: FP 7, render mask problem on Vray 5
« Reply #3 on: February 01, 2021, 03:27:17 PM »
Tks!

TQ2762

  • Newbie
  • *
  • Posts: 21
Re: FP 7, render mask problem on Vray 5
« Reply #4 on: February 03, 2021, 03:12:13 PM »
Hello,

I´ve just downloaded FP 7 beta 4, and it is still with some problems.

They get the render select mask right, but the material Id´s get mixed on the selection when using multimatte element for post selections.

Image 1 has only one object selected, when i select another single object, the Id get´s mixed on the render element.

Image 2 is FP 6, and it works fine.

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 3262
    • iToo
Re: FP 7, render mask problem on Vray 5
« Reply #5 on: February 04, 2021, 07:52:16 AM »
Hi

I can't replicate it. Would You please share Your max scene, and steps how to reproduce it?
Rokas
iToo Software

TQ2762

  • Newbie
  • *
  • Posts: 21
Re: FP 7, render mask problem on Vray 5
« Reply #6 on: February 04, 2021, 10:12:58 AM »
1 - set an object id for a forest pack
2 - set an object id for the custom object or another FP
3 - add a multimatte with the id's of steps number 1 and 2
4 - start an ipr, with render mask selected, to visualize the multimatte element and select  one of the objects. It will show it's id.
5 - with ipr still activated, now select the other object. It will add the id instead of just showing 1 of the 2 id's

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 3262
    • iToo
Re: FP 7, render mask problem on Vray 5
« Reply #7 on: February 04, 2021, 01:31:19 PM »
Thanks for detailed steps. Can't replicate:

Rokas
iToo Software

TQ2169

  • Newbie
  • *
  • Posts: 8
Re: FP 7, render mask problem on Vray 5
« Reply #8 on: March 10, 2021, 08:11:03 PM »
Just download the last stable version, and this issue still exists. Can't use render selected by the alias roolout on vray.

Is this issue going to be corrected?

It is a feature that we use a lot in the office to create masks for post production!

Thanks a lot.

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 3262
    • iToo
Re: FP 7, render mask problem on Vray 5
« Reply #9 on: March 12, 2021, 08:23:21 AM »
it works here:



If You could attach Your scene where it is not working we could take a deeper look.
« Last Edit: March 12, 2021, 09:27:37 AM by Rokas »
Rokas
iToo Software

TQ2169

  • Newbie
  • *
  • Posts: 8
Re: FP 7, render mask problem on Vray 5
« Reply #10 on: March 12, 2021, 05:11:06 PM »
The scene is huge.  gonna prepare a new scene to realease.

But on old Forest Pack you won't need to select the multimat render pass. You would only select the forest element, activate the option in Vray Render Mask (dropdown menu selected) and it would render fine, only this selected object. Good thing of this method would be that in the alpha render element and that would bring a clean B/W mask.

I cannot show because just updated to the new forest pack and, as you can see, I cannot do it again...

Does this explanation makes sense? Hope soo.

Cheers João
« Last Edit: March 12, 2021, 07:00:58 PM by TQ2169 »

TQ2169

  • Newbie
  • *
  • Posts: 8
Re: FP 7, render mask problem on Vray 5
« Reply #11 on: March 12, 2021, 10:55:42 PM »
Dear Rokas,

Just managed to replicate the issue with two diferent forests.
In one (native from the plugin) if you select it and render you can create a perfect mask on the alpha chanel.
Second forest (with generated proxies from our part) if you selected and render the mask comes out black...

Thats the issue I was talking about.

Test scene is large, so follows the wetransfer link.

https://we.tl/t-dwvgQp9aOP

Can you please confirm you can view the file?

Thanks.
Joao

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 3262
    • iToo
Re: FP 7, render mask problem on Vray 5
« Reply #12 on: March 13, 2021, 09:15:37 PM »
Hi. Thank You for the file. Yes proxies had problems but we reverted how proxies are handled in new version FP7.0.7.
I believe Your scene behaves as unexpectedly with latest version.



Thank You for taking time to report it to us.
« Last Edit: March 13, 2021, 09:19:41 PM by Rokas »
Rokas
iToo Software

TQ2169

  • Newbie
  • *
  • Posts: 8
Re: FP 7, render mask problem on Vray 5
« Reply #13 on: March 14, 2021, 04:27:34 PM »
Dear Rokas;

Thank you very much for taking the time to verify this issue!
Going to do the update!

Cheers!
João

SU2154

  • Newbie
  • *
  • Posts: 1
Re: FP 7, render mask problem on Vray 5
« Reply #14 on: May 16, 2021, 06:08:58 PM »
Hi, I am having problems as well with my multimattes and the forest pack grasses and people. They are not rendering at all